WiFi not working - Rock Pi X

I have two of these boards - one running ubuntu and the other windows - neither one of them has working wifi… am I missing something or did I get two bunk boards?

I see there is a bios update on the downloads page for Wifi and BT but I cannot seem to get these to run - there arn’t any usage notes as well - can anyone point me in the right direction?

You need to unpack this file, and copy the files inside to /lib/firmware/brcm
https://dl.radxa.com/rockpix/drivers/firmware/AP6255_BT_WIFI_Firmware.zip

1 Like

So i copied the files to that location, ran the updated firmware in the shell - bluetooth is working, wifi is not - any suggestions?

Figured it out - brcmfmac43455-sdio.ROCK Pi-ROCK Pi X.txt - change the name to brcmfmac43455-sdio.txt

I have wifi issue with Windows10, what location should i put the upzip file? or should i use shell to flash the unzip file? If so please tell the command I am new to linux.
Thanks.

1 Like

I havent figured out the windows side of it yet - so im in the same boat. Also the wifi in linux is sketchy at best.

I am running into the same issue …Ubuntu work good …windows not so much, cant get Wifi or BT on windows.

Bluetooth worked fine once I installed all the right drivers - you can find them in the download section - Windows see’s that there is a wifi adapter installed, but cannot start the device - im sure there is a config file needed or something.

Yeah I got BT working thanks to your other post but I run into the same issues you mention above with the wifi.

Are you sure you connected the wifi antenna? Should work just fine, certainly with Ubuntu.

All drivers are on the download page. https://wiki.radxa.com/RockpiX/downloads

Tried the drivers in the download page and it gives an error “Windows was unable to install”

Edit: have you gotten it to work on Windows?

See here. Windows graphics driver

Yes I’ve got it working on Windows. But Windows is not stable for me. Ubuntu is.

No crashes here just cant get it to work …btw Ubuntu works fine for me I believe.
what did you do …what drivers did you used? …maybe this can be a video you can make

I only had to install the graphics driver. Windows was installed on the eMMC. I used the drivers from the AtomicPi.
Maybe watch this. It’s almost the same hardware except wifi and eMMC and ram size. https://www.youtube.com/watch?v=uD_zxjQ-2BQ

Thanks Nico ill give it a go…btw I have the Atomic Pi folder you posted on my flash drive.

Its a no go …I get the yellow triangle on the wifi adapter in the device manager but when I try to reinstall graphic drivers it tries and it fails. I watched your video and only thing it was different was I had windows create an Installation USB instead of creating an ISO…maybe ill try to re install windows later on. Thank for all the help.

Still no resolution for the wifi adapter on windows 10 lates build …I am really stumped.

Any updates on this?

Check this topic One step forward