What distro to run on 1G NAND


I am trying to fit with everything I will be running inside of 1G NAND. I do need just access to all hardware and working console with few basic tools. We are talking bare minimum with SSH server. In my application card is meant to be as external media or possible future extension for data storage. All applications running will be C/C++ binaries. Maybe compiled and debugged on the RockPi, but not necessarily. I tried Debian and lack of free space did not let me do much even on minimal image. Then I tried DietPi, which (quite smugly) claims to be the best of best minimal distros. This one filled drive without even letting me to console after deciding it will upgrade kernel on first boot.

Is there really something working that fits in 1G NAND or is this feature just good on the paper without any good use? Are there any completely stripped distros with just what is truly necessary?


Vit Soucek

OK so after some more experimenting, I managed make Debian buster minimal to run with some 300MB spare. I guess I cannot make it much further with out of the box images. I will try to lighten it little bit, but this should be more than enough for now. Not sure why this did not worked first time…

Most headless distro’s will fit happily in 1gb its the mem avail that is more likely to have effect.
Your choice is https://wiki.radxa.com/RockpiS/downloads I guess slarm & crux are also slim, with dietpi boasting tiny size and low load.
Its usual for a distro to resize out to full disk and not leave unpartitioned free space if that is what you mean?
Used file space of DietPi should be a touch over 400 MB so a read somewhere but have never used.
What does df -h say after install?

Hi, DietPi showed df with / at 100% even after refusing installation of anything extra. It would be fine if it did not try to update kernel which cannot be prevented. I also tried Armbian but that did not boot after flashing. And I noticed img file was little bit over 1GB, so that might be the issue, that it did not fit (and maybe overwritten beginning?) I did not try slarm, while extracted img was 6GB, so that could never work. I will continue with Debian, seems like the best option. Not sure what was the problem in my first attempt. Just need to figure out not signed radxa repository to install RockPi related packages, but that is topic for another thread, if I get stuck. Thanks lot for your suggestions.

1 Like

how exactly did you manage to strip down that debian image? I ran into same issues like you with the exception that I couldnt even boot dietpi from emmc. The only issue with the stock 902mb debian was that it didnt get an IP address.
Anyways, In case you read this, could you please email me? vit.vitek@gmail.com
Díky předem :smiley:

I did this three months ago, and I did not have much time to try some more since. Stock Debian was fine untill i ran aout of space with just updating aptitude. So next step after getting IP Address :slight_smile:
In the end I used debian minimal (rockpis_debian_buster_minimal_arm64_20200809_0853-gpt.img in my case) and it worked fine. Only problem I ran into was after running sudo apt update it needed to install debian keyring, generated pgp keys, then I updated all. After all was done, I uninstalled using sudo apt-get remove debian-keyring
I wrote myself manual (in Czech) for installation, but I don’t think there is much extra to tutorials here and general linux knowledge. I can send it to you via email when you need.
Doufám, že jsem pomohl :slight_smile: