Usblp on rockpi S

I try to install usblp driver on rockpi S, but it not work, can you help me?

This workaround works.

it not work for me, my rockpis running ubuntu, are you have usblp.ko file? please share with me? tks

when i make usblp.c , it output some error here:
In file included from /home/rock/usb/usblp.c:50:
include/linux/module.h:130:6: warning: ‘init_module’ specifies less restrictive attribute than its target ‘usblp_driver_init’: ‘cold’ [-Wmissing-attributes]
error, forbidden warning:module.h:130
130 | int init_module(void) attribute((alias(#initfn)));
| ^~~~~~~~~~~
include/linux/device.h:1350:1: note: in expansion of macro ‘module_init’
1350 | module_init(__driver##_init);
| ^~~~~~~~~~~
include/linux/usb.h:1195:2: note: in expansion of macro ‘module_driver’
1195 | module_driver(__usb_driver, usb_register,
| ^~~~~~~~~~~~~
/home/rock/usb/usblp.c:1449:1: note: in expansion of macro ‘module_usb_driver’
1449 | module_usb_driver(usblp_driver);
| ^~~~~~~~~~~~~~~~~
In file included from include/linux/usb/ch9.h:35,
from include/linux/usb.h:5,
from /home/rock/usb/usblp.c:59:
/home/rock/usb/usblp.c:1449:19: note: ‘init_module’ target declared here
1449 | module_usb_driver(usblp_driver);
| ^~~~~~~~~~~~
include/linux/device.h:1346:19: note: in definition of macro ‘module_driver’
1346 | static int __init __driver##_init(void)
| ^~~~~~~~
/home/rock/usb/usblp.c:1449:1: note: in expansion of macro ‘module_usb_driver’
1449 | module_usb_driver(usblp_driver);
| ^~~~~~~~~~~~~~~~~
make[2]: *** [scripts/ /home/rock/usb/usblp.o] Error 1
make[1]: *** [Makefile:1471: module/home/rock/usb] Error 2
make[1]: Leaving directory ‘/usr/src/linux-headers-4.4.143-69-rockchip-g8ccef796d27d’
make: *** [Makefile:6: all] Error 2

You can edit the Makefile to suppress those warnings. They pop up because Linux 4.4 is quite old compared to the compiler you are using, so the compiler will now recognize some patterns as problematic.

Here is the patch to suppress this and a few more others I encountered with modern tool-chain. You might need this patch as well.

thanks for the support, the makefile is difficult with me, can you help me build the usblp driver for rockpis (ubuntu) and email it to me, thank you

If you are running Radxa “Ubuntu” OS, not possible to help. I don’t use that very old stuff. Beside I figured out you are asking for ubslp while my hint is covering usbip … which is something else - support for USB sharing.

You can try to generate image with enabling what you need. Beware, Armbian is not perfect but its a lot better OS then “Ubuntu” you are trying to use.


Igor please tune it down. He is asking me to do it and I think that is a perfectly reasonable thing to ask to a vendor engineer. I know you have PTSD on your own forum with this kind of requests but please remember this is a vendor forum.

1 Like

i wait file driver from you

Generally Linux driver is distributed as part of kernel. As such I have recompiled ROCK S’s kernel with this driver enabled. You can download it here:

You should only need the linux-image package which is the kernel, but I included the rest build artifacts for you as well.

After getting the deb on your ROCK S, you can try install it with sudo dpkg -i linux-image-4.4.143-70-.rk3308_4.4.143-70_arm64.deb and then reboot. Make sure after rebooting uname -a shows 4.4.143-70 as your kernel version.

1 Like

great, thanks for support

I gave him professional answer on public forums. What problems do you have? If laughing is not allowed, remove those icons from forums.

Really? Where?

A lot of support on (vendor) forums is done by community. Perhaps open a ticketing system and resolve tickets one by one? Then questions will be directed to you. Until then, you can just say “thanks for providing better / alternative solution for customer of hardware we sell”.

This should allow my comment to have 2 Replies dropdown. You can see now he was directly replying to me. He also talked about makefile which is only mentioned in my comment.

You are getting defensive again. What I meant is that if you feel like something is too time consuming, just refer those requests to us. Unlike you a free volunteer, I got paid to do this, so take advantage of us. We do appreciate how the community is self-helping, so we want to keep it as approachable as possible, which is why laughing at people is not helping.

This is getting quite out of topic. Since the OP already marked as solved, I’ll lock this once you have the final word.

It is reasonable. Just he didn’t ask for a vendor engineer. This is your perception problem. He posted a question on community forums, (even) under section “Community”. He asked for help and he got two different solutions. And he will go your cheaper route where he didn’t need to invest nothing more and will come back again soon … Until you will not be able to help him anymore. Your time, your policy.

“please tune it down” and “PTSD” is not something staff should response with. Volunteers can make any excuse they like to not proceed working for problems your customers have “this is something I can’t help you with” “this takes too much time” “I don’t work with this code” or laugh … Why would I invest more of my precious time to seek your assistance on a problem your user have and I have no interest to resolve? At least not the way you want. I gave him usable hint, but from here he is on his own and I don’t care if he doesn’t understand why this is better.

If a person is asking for help, but acts like jerk, I will probably say something. Next time he might show up at forums, where are no hidden paid support workers that are paid also to eat shit. There is high possibility he might treat community / volunteers, those few people that have know-how and time to help, bad.

Official paid support within forums is benign and its “normal” only because everyone does the same.