USB Touch Screen Kills USB


I’ve recently got a Radxa Zero and everything seems fine except that whenever I try to connect a USB touch screen I have, USB stops working:

[  362.771137] usb 1-1.4: new full-speed USB device number 4 using xhci-hcd
[  362.924340] usb 1-1.4: New USB device found, idVendor=0416, idProduct=c168, bcdDevice= 0.00
[  362.930699] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  362.937956] usb 1-1.4: Product: MTouch
[  362.941646] usb 1-1.4: Manufacturer: TSTP
[  362.945620] usb 1-1.4: SerialNumber: CMTP_1.0
[  373.215132] xhci-hcd xHCI host not responding to stop endpoint command.
[  373.221236] xhci-hcd USBSTS:
[  373.249739] xhci-hcd xHCI host controller not responding, assume dead
[  373.255655] xhci-hcd HC died; cleaning up

I’ve tried using a USB hub, both powered and unpowered but the results were the same.
The touchscreen works find on my PC and Raspberry Pi, though, if it helps, the Pi zero did have issues with it. On the Pi Zero, I had to add the following to /boot/config.txt:


I also tried to use the USB2/OTG port to connect the touch screen but it wasn’t even detected there until I added the following DTB. But, although the USB2 port now detected the touch screen, it still showed the same error as above:


/ {
	compatible = "radxa,zero", "amlogic,g12a";

	fragment@0 {
		target = <&usb>;
		__overlay__ {
			status = "okay";
			dr_mode = "host";

Does anyone have any idea what might be wrong or how I can overcome the issue?
Is there any way to make the USB2 port work?

Thanks in advance!