USB Camera problem

I’m experiencing an issue with a USB3 Vision Camera (Basler, daA3840-45uc). The symptoms is following: high error rate, visual artefacts (apparently due to the errors) hangs after a short while.

I tried this camera (with couple of different USB cords) on a Windows PC and Raspberry PI. While Raspberry struggles to handle a full frame from the camera, cropped frame seems stable. The same for windows PC. It looks like the issue only happen on Rock PI. I’ve seen the camera working stable on it, but don’t see any regular pattern when it happen.

Any idea for troubleshooting the issue?

I had somewhat same issue with the Basler camera, and in my case it failed on usb drive on kernel 5.10. We recompiled kernel with newer version and it fixed it for us

I have the exact same issue with Basler cameras (multiple models). I attempted to tune cpufreq policies to ramp CPU frequency faster when USB load increases, but it didn’t work.

silent-mobius, what version of the kernel did you recompile?

we downloaded version 6.1 and compiled manually on the device

Do you mean the driver is missing in our kernel? If so can you give me the kernel config option? I can add it to our kernel.

TBH, we just downloaded new version, 6.1, and ran make build && make install.

Could you please specify where did you got that 6.1 version that you compiled?

I tried compiling linux-rockchip_6.1.0-1006.6.tar.gz using make defconfig, but it crashed with error: ‘V4L2_MBUS_CSI2_CHANNEL_0’ undeclared here

I am currently working with this system:

Linux rock-mercurio1 5.10.110-21-rockchip #d4b5d0d1d SMP Thu Nov 9 07:07:47 UTC 2023 aarch64 aarch64 aarch64 GNU/Linux

Here is my .config for the Makefile:

root@rock:/home/rock/kernel/linux-rockchip# grep “V4L2” .config

Thank you in advance for any help provided.