Unable to use Radxa APT repo

linaro@linaro-alip:~$ echo "deb http://apt.radxa.com/$stretch-testing/ ${stretch-testing} main" | sudo tee /etc/apt/sources.list.d/apt-radxa-com.list
deb http://apt.radxa.com/-testing/ testing main
linaro@linaro-alip:~$ sudo wget -O - apt.radxa.com/$stretch-testing/public.key | sudo apt-key add -
--2019-12-27 02:55:22--  http://apt.radxa.com/-testing/public.key
Resolving apt.radxa.com (apt.radxa.com)...,,, ...
Connecting to apt.radxa.com (apt.radxa.com)||:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2019-12-27 02:55:22 ERROR 404: Not Found.

gpg: no valid OpenPGP data found.

I am very new to Linux. I am on a rock pi4b and was trying to get my Bluetooth to work. no matter what i tried it wouldn’t find any devices. I eventually tried to get the patch from the repo but it did not work and now I cant install anything with apt
I used the instructions here


Its because you used some incorrect commands.
Dont need to change the $DISTRO in the commands, its a variable.

You can try reverting your action with following commands:

   echo "" > /etc/apt/sources.list.d/apt-radxa-com.list  # to blank out current file contents
   export DISTRO=stretch
   echo "deb http://apt.radxa.com/$DISTRO/ ${DISTRO%-testing} main" | sudo tee /etc/apt/sources.list.d/apt-radxa-com.list  # this is the default
   sudo apt-get update

Then try re running correct command for testing repo add:

   export DISTRO=stretch-testing
   echo "deb http://apt.radxa.com/$DISTRO/ ${DISTRO%-testing} main" | sudo tee /etc/apt/sources.list.d/apt-radxa-com.list  # testing repo for bluetooth
   wget -O - apt.radxa.com/$DISTRO/public.key | sudo apt-key add -
   sudo apt-get update

And then follow the commands here to install the bluetooth patch:

1 Like