Unable to increase tx power on RTL8821CU

I am using hostapd on the official Ubuntu image to use Rock Pi E as Wireless AP, however it appears that the TX Power of the RTL8821CU chip seem to be restricted to 12dBm.

I understand that the TX power is heavily regulated and depends on my country and channel but I am running it on channel 36 US and according to iw list output I am allowed 23dBm tx power, however I am unable to change the tx power using the following command,

rock@rockpie:~$ sudo iwconfig wlan0 txpower 23
Error for wireless request “Set Tx Power” (8B26) :
SET failed on device wlan0 ; Operation not permitted.

While I managed to get 434Mbps bitrate by explicitly setting ht_capab and vht_capab in hostapd config file, I am barely exceeding 60Mbps in iperf3.

Again … setting power will work on Armbian out of the box.

Does Armbian use something other than the 8821cu kernel module ? if so I can probably install that module over Ubuntu.

You can’t install that module over “Ubuntu” since it uses completly different (better) kernel and different (better) driver.

I moved to Armbian buster today, but I am still not able to change txpower.

Try this way:

sudo iw wlan0 set txpower fixed 3000

Also hostapd that is shipped with Armbian is patched to get the most out of it.

I tried, it still stuck at 12dBm,

rock@rockpi-e:~$ sudo iw wlan0 set txpower fixed 3000
rock@rockpi-e:~$ sudo iw dev
phy#0
Interface wlan0
ifindex 4
wdev 0x1
type AP
txpower 12.00 dBm

Debugging this exceeds my reach - driver code comes from:


You might find some hints there.

1 Like