Unable to connect to my main home WiFi

I am trying to connect my Rock Pi 4B+ to my home main network. My router is AX1800 and I enabled smart connect. the connected WiFi “debug ssdi” is my 2.4G guest network that I set for apt update and stuff, every time I tried connecting to the main network it kept giving me error 53 even after I turned off my smart connect. I have no idea how to fix this and I’ve been trying to for hours

try using nmtui - it’s ncurses based menu that is more easy to use.

doesn’t work as well

from error it seems that there is not physical interface…
Lets try using static approach:
Just edit /etc/network/interfaces and write:

auto wlp1s0
iface wlp1s0 inet dhcp 
                wpa-ssid {ssid}
                wpa-psk  {password}

After that write and close file and use command:

sudo dhclient wlp1s0

Replace {ssid} and {password} with your respective WiFi SSID and password.

I wrote that and run the sudo dhclient wlp1s0 and got "Cannot find device “wlp1s0”, reboot the rock pi and try again and still got the same error

can you share output of

ip addr sh

change wlp1s0 with wlan0
Please look that it seems like you have IP address, and it should let you use network.

am I supposed to change the /etc/network/interfaces back to its original state or change the wlp1s0 to wlan0? yea sorry I don’t know much of these Linux stuff

change at /etc/network/interfaces file the value ofwlp1s0 to wlan0

so basically this?

auto wlan0
iface wlan0 inet dhcp
wpa-ssid {ssid}
wpa-psk {password}

(edit: how do I even format more than 1 line code)

yes - use nano editor which like windows notepad

it works! also I meant in this website, how do I make code block in my messages like you do. And one more question, if I wanted to make a app that changes the Wi-Fi SSID I just had to make my program edit that file? say a Rust program.

Mazal Tov !
that’s too many questions in one message :slight_smile:

  • regarding syntax and code, read about markdown
  • in Linux, when ever you wish automate things, it is usually done with shell script. I usually love to learn with challenges, I used exercism for this. give it a try.
  • also read this book for basic Linux understanding. it is old, but has all you need to manage.

The wifi problem has been around for sometime and Radxa won’t do a thing about it. The 4C plus is a disaster. Support for it is non existent. I have two. I have tried every Linux distribution for it that exists. They all have problems. I would like to return mine and get something that works. The Raspberry Pi can be loaded and up and running in 15 minutes or less. Hardware isn’t worth anything if there is no software to support it.