Ubuntu server stuck on reboot

Is there a way I can get a log during a reboot? I’m sure it has to do with my current configuration. At some point ‘sudo shutdown -r now’ stopped working. It can tell it shutdown, but seems like never comes back up. I have to pull the plug and plug it back in.

You can try Reboot or Restart command to restart board

I’ve tried ‘sudo reboot’ with the same result.

Can you get logs from serial console?


/var/log/kern.log is the file where you should look for kernel messages, both startup and shutdown.

For comfortable view you can rename/backup/delete this file to see only messages from last shutdown/startup.

Ok thanks, I’ll check there. I don’t have that USB cable, I’d have to make it up, so hopefully I’ll find my answers in the log file.

I meet similar issue.
board get stuck when reboot.
the root cause is uboot fail to detect SD card when reboot, you can not get file logs in this case.

Same here. Not possible to reboot or shutdown in most cases.

Is there a possibility to switch off acpi as suggested in this general ubuntu thread https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1594023 ?

Not sure how to do it without a boot loader such as grub …