Ubuntu server kernel issue

We will take this seriously. We have checked the armbian kernel device tree, it’s mostly the same as ours. Need more digging. We tried to reproduce it in the office before but we did not see it.

@Nechoj what sd card are you using?

I’m using a 64GB eMMC

I tried different cards:
Samsung EVO 32GB
SanDisk Ultra HC1 16GB
Transcend Extreme-speed 16GB

all cards have been UHS-1 / class 10.

Note: the errors in the SD card interface were gone, when I applied the dtb patch mentioned above to the Ubuntu kernel. Then I switched to RockPi Armbian and likewise, no SD card errors showed up.

What remained are the errors in the dhd_tcpdata_info_get which are related to the WiFi interface. Those errors show up in Armbian as well. Surprisingly, these errors are being logged in the kernel log, but the wifi interface does not report any lost data.

I am running ubuntu since 1 week (boot device is a 64GB eMMC card) and yesterday the rock pi crashed after hundreds of
bcmsdh_sdmmc: Failed to Read byte F1:@0x1001f=ff, Err: -5
errors.
So the problem still exists and I have to try another image.

And also
bcmsdh_sdmmc: Failed to Write byte F1:@0x1001f=00, Err: -5
errors.

Is there any advancements on this. I just had the same issue. RockPi crashed after around 30 days of uptime.
Running Ubuntu 18.04.1 Linux 4.4.154-59-rockchip-g5e70f14 on a 32Gb eMMC and nvme SSD.
Got the same errors before locking up.

[ 275.201939] bcmsdh_sdmmc: Failed to Write byte F1:@0x1001f=00, Err: -5
[ 275.202920] bcmsdh_sdmmc: Failed to Read byte F1:@0x1001f=ff, Err: -5

I updated to the most current kernel (4.4.154-83) as indicated https://wiki.radxa.com/Rockpi4/radxa-apt.
Since these errors takes some time to show up, I will come back to report if it continues to happen. Unless the update fixed the issue.

This output should not crash the ROCK Pi 4. If it crashed, there must be some other reasons.

This looks to be the the same issue noted here and is “resolvable” by blacklisting bcmdhd, but then you lose wifi.

It’s not “crashed” as such, it’s still running but not responsive. The log file fills up with a stream of those errors but there is not getting into the machine other than to reboot.

Same problem. How to fix it?

You could try the new images by ayufan

https://github.com/ayufan-rock64/linux-build/releases/download/0.9.0/bionic-minimal-rockpi4b-0.9.0-1142-arm64.img.xz

https://github.com/ayufan-rock64/linux-build/releases/download/0.9.0/stretch-minimal-rockpi4b-0.9.0-1142-arm64.img.xz

Hey guys,

I’ve recently received a Rock Pi 4b, 128gb emmc, and m.2 extension board - all from Radxa. I’m currently using the emmc with the Radxa Debian Stretch image. Ran all the apt-get upgrade/updates, and did some adjustments to make it so it would fit my needs.

I’m currently experiencing the same issue…
Oct 11 15:32:18 kopono-server kernel: [ 895.579146] _tdata_psh_info_pool_deq 200: Out of tdata_disc_grp
Oct 11 15:32:18 kopono-server kernel: [ 895.579680] dhd_tcpdata_info_get 1092: No more free tdata_psh_info!!

I’ve got the external WiFi antenna on this Rock Pi 4b, and a 1TB M.2 Sabrent Rocket drive…

Can anyone confirm that Ayufan’s build works without issues? Thanks…

Hey I’m trying to load the ayufan images onto an eMMC, but all of them don’t boot? or am I just missing something and not getting HDMI output? I get a solid blue on the board, so I’m thinking it’s processing or something… but nothing ever comes up on the screen.

I’ve tried the stretch, disco, and bionic minimal images for the rockpi4. Can someone help point me to the right direction on getting these custom images loading properly? Thanks.

Couldn’t get Ayufan’s stuff to work at all. Probably cause it’s “pre-release” builds… and the fact that I’m not smart enough to figure out how.

Ended up using official Armbian images.

I have no SD card at all, using SPI Flash+NVMe, but experiencing the same issue, so probably it’s not related with uSD card speed or quality.

Try to update to the latest radxa 4.4 kernel.

https://wiki.radxa.com/Rockpi4/radxa-apt

Hi, I have the exact same issue.
bcmsdh_sdmmc: Failed to Write byte F1:@0x1001f=00, Err: -5
Is there a fix ?
In the mean time, I will try blacklisting bcmdhd as @bork99 suggested.
Thx,
Antoine

I think this issue is fixed upstream. Please update to the latest rockchip 4.4 kernel.

1 Like

Thanks @jack. I Updated the kernel yesterday to [4.4.154-95]. Seems to work fine for now.
I will come back to this thread if I see some errors later.
Have a great day

Issue has been fixed as the Rock Pi works fine until now.

1 Like