Ubuntu server kernel issue


#22

That’s great, because I’ve seen posts like this on RasPi forum (i mean posts about microsd card problems).
And as i posted just a bit above, this kind of problem can be solved with upping voltage for microsd card, but if microsd A works and microsd B doesn’t work it’s not always board failure.
Still i would advise for you to normally test it, not with what you tested it. Low-cost microSD always brings more pains than they cost.


#23

I bought my eMMC from an Austrian distributor. As I installed the heatsink it is not really possible to get the card in and out. I will try to install the image on a samsung sd card and then to boot from this device. No idea yet how to make dual boot with only command line, but will see.


#24

Besides the SD card interface problem, there is stil the issue with the wifi driver:

dhd_tcpdata_info_get 1092: No more free tdata_psh_info!!
_tdata_psh_info_pool_deq 200: Out of tdata_disc_grp

Whenever the wifi module is activated, the /var/lib/kernel.log is flushed with these errors.

The responsible module in the rockchip kernel is

kernel-release-4.4-rockpi4/drivers/net/wireless/rockchip_wlan/rkwifi/bcmdhd/dhd_ip.c

My wifi network is managed with netplan and systemd.networkd, as recommended by the ubuntu community.

Is there an idea how to solve this problem?


#25

I view the log files with “cockpit”, but there are so many errors that I want to view them with vi editor. Can you help mit with finding the directory. Nrmaly the log files are in /var/log, but there is no syslog.
Thanks Norbert


#26

Hi. You do need to know that many SD-Cards are fake. Many Samsung, Sandisk, … are fakes. Even when buying at a know shop you are not certain of buying a genuine product.
They look almost identical, only a few small points where you could see it when it’s not a real one. Many times the text written on it isn’t very clear to read. Also sometimes the color is a little off on the package.
The best way to see if it’s real is look on the back of the card to the fineprint. There’s a serial code and where it’s made. Many fakes don’t have this.
But all that is also faked now.

Many/most amazon sd-cards are fake. In Belgium we’ve got big well know super markets who sell fake Sandisc sd cards.

So don’t think because your card can read and write that it’s ok. As @Dante4 says. 4MB is way too slow. Even when it goes thru a virtual box it shouldn’t slow down that much.
Many of the sd card problems are because they are not using genuine sd cards. So it may be that yours isn’t genuine.
I’m not saying it is, but it sounds like it.


#27

Did you mistake something for something? I also know SD card fakes, but eMMC are something completely different. There’s hardly a SBC manufacturer that doesn’t put eMMC on a small board to sell it with “its own plug”, as "its own eMMC. It’s not worth faking eMMC for a SBC at the low quantities. Only the Raspberry Pi is sold in such quantities, but unfortunately it can’t use eMMC.


#28

Hi. There is a distributor which sells all the Radxa products. I bought my Rock pi, the heat sink and the eMMC card there. The boxes of the products all look very originally. I do have the write errors and many more kernel errors with both sd-card (original Samsung Ultra 128GB) and the eMMC card. I will now try to install an other image (Debian or Ambian) and see if there are the same problems.


#29

Did you mistake something for something?

I answered on this:


#30

Just to be sure. Are you using a good power supply with quick charge? Power issues can lead to write errors too. If it’s both with your eMMC and SD-Card, then maybe it’s something else. What cable do you use? What power supply? Are you powering anything else with the RockPi?


#31

In the meantime I solved the read/write error problem with a change to the raxda kernel dtbs as suggested by @trulyliu above. Many thanks for that extremely useful help!

So, all my ‘fake’ cards work properly now. Btw., faked cards are usually recognized by the capacity test that I did using the f3 tools. And: Faking 16GB cards is not very interesting for criminals. They want to sell 128GB+ cards that actually contain much less capacity.


#32

I use a quick charge power supply and there is notching connected except Ethernet. I do have I macbook power sapply and I think there is somewhere the info that I can use this to power the Rock Pi - is this true? The interesting thing is, that I have single write errors all the day, but today at 1 pm there are more than 100 in a short time. I only installed the ubuntu image and cockpit to view log files - as I wrote before I can not find the syslog file under /var/log and I do not have any idea where it is.


#33

They sell 16gb non sandisc as sandisc. The bigger sizes are most of the times not true size, but the smaller ones are. If you can sell a $5 sd for $15, then that’s still very profitable. Greetings.


#34

I now installed Armbian on my samsung sd card and since one hour not one single write error. I will run it until tomorrow evening and will then write the result. There are also much less kernel errors than with ubuntu image. The only problem I have is that my Apple usb keyboard is not working with debian or armbian distribution.


#35

Make sure that rsyslog has not been disabled. You could check with

sudo systemctl status rsyslog

If it is not up and running, do

sudo systemctl enable rsyslog
sudo systemctl start rsyslog

If rsyslog can not be enabled because it is not installed or the installation is faulty, do

sudo apt install --reinstall rsyslog


#36

Was not installed - thank you.


#37

Hi. I am running armbian image now on my sd card since 24h and not one read/write error.


#38

I’m getting ‘Failed to Write byte …’. Some one said: ‘raxda kernel dtbs’. I’m running Ubuntu 18.04.1. What does it mean to use ‘raxda kernel dtbs’ and how do I do that, or how do I find out if i’m not already or already am?


#39

First at all run update & upgrade, because there .02 version out


#40

Updated and upgraded, now running 18.04.2, but still seeing the same:

Mar 6 15:22:15 localhost kernel: [ 227.064519] bcmsdh_sdmmc: Failed to Write byte F1:@0x1001f=01, Err: -5

I’ve a 64g emmc and a 120 g nvme. The board hangs every 2 days or so. I’m looking for possibilities as to why and that error seems to stand out.


#41

Then let’s talk about dtbs. You can’t run any OS without proper dtbs, because it’s place where all devices described, so, yes, you is running Radxa dtbs. But to fix your problem… I can think of 3 ways

  1. Use merge that was linked earlier (not safe)
  2. Try Radxa’s Armbian
  3. Try Armbian’s Armbian from Armbian’s site