Ubuntu do-release-upgrade fail do to space limit in /boot

Hallo,

since a few days after I log into my Rockpi 4 running Ubuntu it says:

New release ‘20.04.1 LTS’ available.
Run ‘do-release-upgrade’ to upgrade to it.

But when I try, it stops because it expects 110 M free space on /boot but it only has 62M left with 38 M in use.
So what to do in this case.

(I’m an experienced Linux user for some years now, but this is beyond my skills)

Regards

Frank

It should be designed other way, for example /boot/ partition should be bigger in the OS image,
but for now what you can do is resize following partition (move start of the partition ahead, 512 MB) and resize the boot partition with GParted.

Dear pbies,

thanks for your advice. I first had the idea to follow it, but when I did a look in my MMC partition table I thought it’s not a good idea. Tinkering with partitions is still to dangerous for me.
Suddenly I remembered, that I was using an old kernel version (vmlinuz-4.4.154-59-rockchip-g5e70f14) because I had not fully followed the steps mentioned here. Yesterday I followed these steps and updated the kernel to version vmlinuz-4.4.154-110-rockchip-gcef30e88a9f5.

So I decided to start do-release-update today again and this time, it worked. Took about half an hour to do the update and now I’m on Ubuntu focal (20.04).

The difference seem to be, that the release-update does not start to build a new kernel, if your kernel is up to date. It just uses the one that’s “shipped” with Rock Pi 4.

So if anyone stumbles over the same behavior of do-release-update on Rock Pi, just give updating the Rock Pi kernel atry following these steps.

Regards

Frank

Thanks also, because I just updated mine Pi to 20.04.1.

Some fixes were needed to run www but simple they were.

@FrankNFurter haven’t you observed limited performance of Ethernet after this upgrade?

I’ve got earlier 1000 Mb/s, so I got 115 MB/s via Samba,
but now I cannot go over 11 MB/s…

Strange is that the Ethernet connection is in fact working at 1 Gbps but there is no way for me to achieve earlier speeds…

Dear pbies,

I have tested it now using iperf with three values of --len parameter of iperf (TCP buffer size) I used a buffer size of 128, 256 and 1024. On Rock Pi i started iperf in server mode and the connection was routed over a low level firewall hardware running ipfire firewall to my personal computer. On this I called iperf in client mode.

On all three test I get a performance of about 500 Mbit/sec, what is much more than you have got but less than 1 Gbps. Reason here I guess is my small firewall hardware.

Hope that helps.

Regards

Frank

@FrankNFurter thanks for the info.

I suspect this recent upgrade to 20.04.1 lowered my speeds.

I will need to move to Armbian in this case. I am not happy that I will have to configure the whole system once again. I’ve put much work into it.

Dear @pbies
hope that is not the case. It alarms me that you tell an Ubuntu release upgrade brakes your interface bandwith. Have you opened an new thread here in this forum about that. I gues that many people use a rock pi as a firewall or small web server or something. A 10 Mbit performance breakes this concept.

Setting up a new system should always be the very last option.

Regards

Frank

@Stephen @jack guys, do you observed such problem as we are talking here or know why it happens, that after upgrade to Ubuntu 20.04.1 with kernel 4.4.154-110-rockchip-gcef30e88a9f5 I am getting worse Ethernet speeds?

Home network is 1 Gbps, all Ethernet, not Wi-Fi, earlier (before upgrade to this Ubuntu) speed for samba was 115 MB/s both ways between PC, now it is 10 MB/s or ~50 MB/s depending on I don’t know what…

On Armbian I am getting ~15 MB/s. Disk benchmark gives ~300 MB/s. So it is networking problem. Ethernet on Rock (ethtool eth0):

        Speed: 1000Mb/s

Dear @pbies and of course @TheDude and other benchmarkers,

I have seen that you all have done a lot of benchmarking but I miss a ethernet benchmark. has anyone else than @pbies and I done such benchmark?
IN my post above I have not done a real benchmark because between the testing machine and the rock pi there was another device in between, but i reached about 500 Mbit/s with that setup.

This is much more than @pbies reported using the same operating system. So I guess either, that @pbies Rock Pi has a hardware defect or other hardware he uses along the wire has one.

@pbies: Have you tried the test with other cables, router and so on. Is your power supply and cooling ok. What does the cpu benchmark tell at the moment?

Regards

Frank

@FrankNFurter hardware setup didn’t changed on my side. PSU and cooling are ok and also hasn’t been changed.

Got it!

Samba is the problem. FTP works 115 MB/s.

So seems like one of the recent samba updates.

EDIT: I commented out the below line in smb.conf and it works perfectly!

; socket options = TCP_NODELAY IPTOS_LOWDELAY SO_KEEPALIVE SO_RCVBUF=8192 SO_SNDBUF=8192

I’ve done second do-release-upgrade. What I can share is to mess with /boot folder contents:

You should have boot files in /boot folder, but do-release-upgrade makes problem with free space on that partition (in this case it should have mounted /dev/mmcblk?p4). What you need to do is umount /boot, clear the contents of that folder (should be empty already) and then do do-release-upgrade. For fast eMMC (from Allnet China) it takes below 1 hour.

Surely, it would be nice to make a backup copy of the /boot folder, what you can do by this command:

cp -ra /boot /boot.old

If the kernels differ you would need to connect eMMC/microSD to PC and copy all files from /boot folder from 5th partition ext4 to root / folder of 4th FAT16 partition.

And that’s all! You have Ubuntu 20.04.1 LTS now!

For now the latest kernel is:
4.4.154-110-rockchip-gcef30e88a9f5

The above was verified.