Ubuntu bridge interface

My environment:

  • ubuntu eoan (distro upgrade)

  • Rock Pi E with USB to Gigabit LAN (alias as eth2)

  • bridge interface (br0) on these LAN ports eth1 eth2

  • assign static ip to br0

  • eth1 connect to internet gateway

  • eth2 connect to switch and PC1

  • PC1 can get ip address from internet gateway router (through br0)
    and can access the internet

  • PC1 cannot ssh to Rock Pi E

  • Rock Pi E eth0 get ip address from dhcp (another router)

  • PC2 connect on

  • PC2 can ssh to Rock Pi E via ip address

Question : what 's the problem on br0 ssh?

Thank you for any help.

It would be helpful to see dumps of both your interface and ip-tables configuration. And also output of lsof -nP -iTCP -sTCP:LISTEN | grep ssh (as root) to see that sshd is listening on all interfaces and not just one.

My first thought is something wrong with the bridge configuration - sounds like you’ve assigned the IP address to the bridge and not to the interface (which is correct). Try to simplify - can you ping the static IP from both eth1/eth2 via direct connection to PC without anything else connected?


Thank you for reply.
Both bridge and eth get ip from dhcp with interface ip setting in manual (something wrong here). and sshd bind on address.

I will dump information soon.

I have fresh install it and get distro upgrade.
for now it work. So, I do not know what wrong with my first try.

@blu33agl3 If your issue was resolved, you can marked the most appropriate post as the solution.

Refer to this image:

1 Like