UARTs and Serial Consoles

I have a couple MAX3232 UART <> RS232 devices and couple CP210 UART <> USB bridge devices and I’m scratching my head trying to get a serial console running on UART2 (GPIO pins 6,8,10) or UART0 (GPIO pins 9,11,13).

On the Rock Pi X side I’m using CentOS 8 and I’ve tried every combination of console=ttyS0,115200 [or ttyS1, or ttyS2] on the GRUB kernel line at boot. I’ve also tried enabling serial-getty services for ttyS0, ttyS1, and ttyS2, but appending to the kernel line should do the job in any case.

On the Windows/PuTTY side, I’ve tried every combination of line speed and other serial settings/flow control, etc.

Has anyone else found the winning combination? The clearest information I have comes from the following link:

I wouldn’t mind experimenting with the debug UART on the bottom of the board, but I can’t seem to find the serial converter with the flat ribbon cable shown in the above link. Any idea how to search for that or where to buy?

Many thanks!

If you count the pins with the flat ribbon cable, they are 10. Search for " 1Pair 0.5mm pitch Connector SMT Adapter to 2.54 mm 1.00 inch pitch + 0.5mm pitch 50/100/150/200mm Length FFC Cable 6/8/10/12/50P" in Aliexpress and select 10P. @jack Could you confirm that’s is 10 pins?

Hi Zaza

Thank you! I also count 10 pins and you’ve given me some good clues for searching. I think these two items will meet the need:

…which means I’d then need to understand which pins on the debug UART are RX, TX, and Ground. Maybe this is in the specifications; I’ll check.

Any ideas on my technique using UART0 or UART2 for this purpose? Based on my experience with other SBCs (LibreComputer, RPi) a serial console is spawned on the GPIO UART “by default” (but this may be how they’ve built their disk images). Am I missing some step for enabling these UARTs? Or perhaps I’m inferring from other threads that a GPIO interface hasn’t been fully developed/released yet?


Currently I’m not using Rock pi X through serial consoles. I don’t have the 10 pin flat cable to test it either. I installed the Win 10 home edition and I’m tackling the wifi problem which doesn’t show up. Have you tried access the serial console with linux? I think it is more easier to config than windows, then you could try with Win10. The RX TX GRD pins can be found in the schematics of ROck pi x, it’s in the page 19. the 6 pin is GRD, 7/TX, 8/RX. If this don’t work, change the order of RX and TX.

Thank you, Zaza, that pinout information is a big help. Parts are on the way and I’ll report back on my progress (hopefully success!)

I find PuTTY-on-Windows and Minicom-on-Linux essentially interchangeable in terms of configuration and use of a serial console. I’m highly confident that the issue is squarely with the serial port setup in CentOS on the Rock Pi X.