UART2 is busy. UART4 does not works

Today I get this powerful computer and I must say that works so far so good except one thing. I use RockPi as companion computer which communicates over UART with a microcontroller. I installed these packages:

 $ sudo apt-get update
 $ sudo apt-get install rockchip-fstab
 $ sudo apt-get install rockpi4-dtbo

then I edited /boot/hw_intfc.conf:

# Hardware Interface Config

# For more details, check

# Set "on" to enable the optional hardware interfaces while set "off" to disable.










# Devicetree Overlay Enable, uncomment to enable .dtbo under /boot/overlays/.

# EEPROM on I2C2


# Serial console on UART2


# Serial console on UART4


# Dummy spi device on SPI1 for test. Need set: intfc:spi1=on


# Dummy spi device on SPI2 for test. Need set: intfc:spi2=on


# PCIE running on GEN2 mode


# ALLNET 4duino B10/B11 two-coloe-led module on 40-pin Header Pin#35 and Pin#36


# waveshare 3.5inch lcd (B v2) on SPI1. Need set: intfc:uart4=off and intfc:spi1=on


# waveshare 3.5inch lcd (C) on SPI1. Need set: intfc:uart4=off and intfc:spi1=on


problem is that python throws this error. I think that debug on uart2 is still active.

serial.serialutil.SerialException: [Errno 16] could not open port /dev/ttyS2: [Errno 16] Device or resource busy: ‘/dev/ttyS2’

Maybe the console shifts after uboot but uboot is fixed to ttyS2.
I am sure I saw a dtc overlay to turn the console off but just been looking and can find it.
I am running manjaro at the moment but seem to remember the kernel parameter was ttys0 and is part of the boot config so maybe check there also.

I have a serial console but manjaro do have it set to ttyS2

Hi, I would suggest you to update these packages including rockchip-overlay, u-boot, kernel and rockpi4-dtbo, etc.