Good morning, I have to connect two NFC PN532 readers to the Rock Pi, the easiest thing is to do it through i2c, but since they have the same address, I can’t.
The other option I have is for UART, but it doesn’t work for me. Do I have to enable / disable something in the OS for the UART to work?

I have tried following the diagram of my version (1.2) on both UART1 and UART2 without result.

Any ideas?

Thank you !

Since the address is not settable on that device, if you want to stick with i2c, you have two options;

  1. Use an i2c multiplexer.
  2. Use a separate i2c bus for each device.

However as you’ve also noted, there are other interface options, including uart and also, spi. I can’t answer why i2c didn’t work for you.

Also note that you referred to a diagram, but there is no diagram attached to your post.

Hi, @Atarax

According to the ROCK Pi E PINTOUT, you can use I2C1, UART1 and UART2 for your devices.

If you use Radxa Official system image, to enable I2C and UART, etc, you can view ROCK Pi E Common Hardware Interface.
scroll to the bottom and click on expand link next to RK3328 Available Overlay (ROCK Pi E)
This explains the UART overlays and what need to happen.
The following is how I enabled the UARTs:

Edit the uEnv.txt file with the Linux Nano Editor
rock@rockpie:~$ sudo nano /boot/uEnv.txt

Edit uEnv.txt and add the names of the two overlays without the file extension to the “overlays” variable

overlays=rk3328-uart2 rk3328-uart1

Now we CTRL X to exit, Y to save, ENTER to select filename. Nano will automatically close

Thank you very much for your reply,

For me, the ideal would be to be able to activate a second i2c bus, by default, the i2c1 is the one that brings on pins 27-28. Can it be activated on two other ports?
I think in version 1.2 of harwae the command
overlays = rk3328-i2c1
Does nothing

Thank you!