UART no longer works after update

Hello,
On some tests I updated to latest radxa ubuntu and kernel, probably it updated something more than just sd card (maybe spi?). Soon after that I reboot board and it did not start again (no blue led). I flashed image to eMMC and system booted again with eMMC only.
Later I tried few other things and found out that it won’t boot anymore with uart console attached. Same that worked perfectly some time ago. I checked another uart console with same effect. Then I get second rock3a board and that one works with both uarts. Same setup - card, charger, cooling, the only difference is v1.2 vs v.1.3 board revision but according to @jack this should not be big difference.

Then I tried RKTools instructions found on wiki, trying to burn spi with latest u-boot and loader. No luck :frowning:
Then with cleared SPI - still nothing.

Any ideas how to make UART to work again? For now no matter what Im trying it won’t boot with uart cable conected. Nothing on com port and won’t boot into the system. It’s even worse than when I connected not supported UART cable which caused to stop at u-boot.

On RKTools there is tab about firmware - what firmware is that? and how to updated this one?
Of course I still can boot into system and try to update or read anything just from there. Also I still have another board with working UART to compare (or update ;))

any ideas? @jack @Stephen ?

this may be the same issue as @james.kraber - I expected that with right UART console board should write some information on boot, right now mine is not booting with console.

any ideas?
Is there any way to revert bootloader to older version?