Trying to FLASH SD Nand, Stuck on downloading bootloader

I am following the instructions here:

The Pi S is in maskrom mode, as I see the device listed with rkdeveloptool ld command.

However, upon inputting the command: sudo rkdeveloptool db rk3308_loader_ddr589MHz_uart0_m0_v2.06.136sd.bin

I get “Downloading bootloader…” and it just hangs there, I never get an indication that downloading the bootloader succeeded.

I have also tried to use RKDevTool on Windows, which also indicates the device is in Maskrom mode. This time trying to load the bootloader fails with an error “Download Boot Fail”.

Anyone have any ideas? If I can’t flash the SD NAND maybe my board is just DOA and I need to RMA with Allnet?

1 Like

That loader seems to be really new. Maybe try an older one?

I tried the old one and got the same result. At any rate, it appears that the newer rock pi s’s use a newer version of the RK3308 and would need the newer loader anyways.

Yes, newer ROCK Pi S with RK3308BS requires new loader since the operation voltage is different. Can you attache a serial console to check what’s happenning?

I don’t have a USB to TTL cable, but I did just order one. Interestingly enough I cannot get the board to boot via SD card either. I contacted Allnet China to get an RMA but they have seemingly ghosted me.

Ugh I bought PL2303TA chip and it doesn’t have support for 150000 baud rate. I should have paid more attention to the serial console guide. I’m ordering a FT232RL cable now.

I received my FTDI USB to TTL cable today, and I get no system startup information upon booting the board in Putty. Also the board will not boot via SD card. This thing is dead as a doornail other than the pretty green light that indicates it’s at least getting power. I’m trying to work with Allnet China on a replacement, but they have ghosted me. Can Radxa provide any help?

EDIT: The driver port settings do not go up to 1500000 for the baudrate, it maxes out at 921600. Could this be my issue?

Same problem, still exist

I too have this issue. Have been able to flash many devices months ago but now no longer. Have tried the windows tool as well as the latest rkdeveloptool (which has a bug requiring a code change/workaround to compile) with no luck. I have tried multiple variations of devices, cables, laptops, and operating systems.

That loader seems to be really new. Maybe try an older one?

This worked for me w/ ROCK PI S V13 20190910

I should point out though that the current version of rkdeveloptool hosted on github doesn’t work - I had to compile PR57 - and then use this older bootloader… but then it worked.

for anyone following this breadtrail in the future: whenever cloning rkdeveloptool, interject the following commands before building:

git clone
cd rkdeveloptool
git fetch origin pull/85/head:local_fix
git switch local_fix

and then use the older boot loader linked above

Hope this helps someone!!