Trouble with audio recording

Hi everyone,
I’m currently struggling on recording from the audio jack, which should be possible, no?
I installed Debian and am perfectly fine playing sound files with “aplay”, but using “arecord” to capture data from my microphone just produces static noise. I’d guess that I somehow need to switch from playback to capture but after hours and days of searching the internet and trying different things, I still made no progress.
So, can anyone of you help me with that? I hope it’s a simple task, just complicated by my inexperience.

Best regards,
Tim

I would just like to also add that I’ve similarly not been able to make the microphone jack work.

1 Like

Hi Tim,
same problem with me! Could you find out something?
Spec of ES8316 audio-chip says 3,3Vrms max as input. Normally, depending of Mic-Type, MicBias has to be switched on/off. It looks like it is swiched off and so you need a signal input-voltage of about 3 V for fullscale input. I couldn´t see any voltage on the Mic-Pin. I took a pre-amplifire with ~3V output and it worked.

The question to Raxda - is it that way? And if yes, how to swich MicBias on/off?

Hi,
I worked around the problem by using a small USB sound card. It wouldn’t record from it at first either
because I had to switch default to it, using
“pactl” + “list short sources”,
“pactl”+“set-default-source”+“card name”
I did neither check if the default was set correctly beforehand, nor did I try it again with the onboard jack,
because now everything works just fine, the Rock is fast and competent in doing what I want it to.

Greetings
Tim