Taco setup problems


I recently got a Taco and I’m having trouble with getting it to work with a Raspberry Pi CM4. When I plug it in I get a red power light but no other LEDs light up.

I’ve tried booting from an SD card with the Raspberry Pi OS image created with Raspberry Pi OS imager but I get no signal to the monitor.
I have also tried using USBBoot but I’m permanently stuck on Waiting for BCM2835/6/7/2711. I’ve tried this using two different computers, one running Ubuntu and the other MacOS. The CM4 board and the Taco both get warm so it seems like something should be happening but I aside from the power LED I see no other signs of life.

Does anyone have any tips or ideas? Did I just get a bad board?

1 Like

Sorry for the late reply.

Micro SD cards only work with CM4 lite version. The CM4 and the Taco both get warm, which is not normal.
I’m afraid the screws on the heat sink are too tight, causing the board to deform. Can you try to loosen the screw and try again?

Hi @setq,

That’s interesting. I got the Taco a few weeks ago and setting it up at the moment. So far so good, I was able to install rpi os bookworm. Great! But yeah, I noticed the tfcard slot doesn’t work, and reading your comment, I kinda get why… But what if I can manage to put some extra cooling devices for both the none-lite CM4 and the taco? Could I have an sd card working?

Also, no psu and fan were included with the taco I got, which is problematic. Then, I can’t figure out what kind of screws to use to secure the CM4 (M2?), and the fan connector is unknown. Could you provide any help with that?

Finally, I wish there was an USB3.0 port. By any chance, do you know of any USB3.0 card to fit the key E slot?

Thanks in advance for some quick answers!

Hi @8jef

Micro SD cards only work with the CM4 lite version.

Yes, the screws are m2. The fan connector is 2-pin 1.25mm.

I don’t know about this USB adapter card.

Hey @k_taco !

Did you ever figure this out? I’m facing the exact same situation with the Taco board and a non-lite CM4.

1 Like

Hello there,

I’m also experiencing the same issue with the Radxa Taco in combination with the Rapsberry Pi Compute Module 4. I have followed the installation guide as outlined on the wiki.

If I pug in a 12V 5A power supply, the indicator light turns red. However, nothing else seems to happen. After connecting the Taco to a MacBook via a USB cable and running sudo ./rpiboot, it also gets stuck on Waiting for BCM2835/6/7/2711....

Here are the specifications of my setup:

  • Raspberry Pi Compute Module 4
  • 4GB RAM
  • 32GB eMMC flash memory
  • 12V, 5A power supply


I could not get rpiboot working, so I tried a different approach: I flashed Raspberry Pi OS with desktop on a SSD with USB connector. Then I connected a screen using a HDMI cable and it seems to boot normally. Then I did the same with Raspberry Pi OS Lite and configured SSH settings before flashing it onto the SSD and connecting it via an Ethernet cable to my modem. With LanScan I was able to find and SSH into it.

Does anyone know how to boot Raspberry Pi CM4 with eMMC from a Radxa Taco using a SD-card card or the eMMC? After numerous attempts, I have only been able to succesfully boot the device from a USB-device (see previous post). This is not ideal for many reasons.

The instructions on the Wiki page do not seem to offer any solutions, nor do they seem to work for the Raspberry Pi CM4 with eMMC. Hope someone on this forum is able to help out.

From my understanding, it is not possible. Rpi4 has only one SDIO controller. So if the CM4 has eMMC, the signals are routed to the eMMC and thus not usable for SD card. CM4 and CM4 Lite differ in PCB layout. Only the Lite version has signals routed to the connector for SD card use.

As @Filip_Kotoucek writes, if you have the EMMC version you can’t use the SD card.

I never got flashing the EMMC to work on the Taco. I ended up using a PiTray mini to flash an OS to the EMMC and then I plugged the CM4 into the Taco - and that worked.