Taco + CM3 not seeing m2 SSD nor SATA drives

I bought Taco + Radxa CM3, it boots from sdcard fine into ubuntu 20.04 (the “io board” version), and updates after installing the new Radxa key just fine to latest version. HDMI, only the one of the wired network ports, onboard MMC, SD, USB work just fine, but neither m2 NVME SSD, nor SATA drives are detected.

Is this normal for Radxa CM3, and the rest will only work with Raspberry CM4?

Hi silverj,

What does the following commands output?

lspci
dmesg | grep pcie

Neither show any output.

Try using e23 image https://github.com/radxa-build/radxa-e23/releases/tag/20221101-0111

With that image, HDMI no longer works (which would be fine for me), SATA drive (just tested with 1) is detected ok, but the NVME m2 drive is still not detected.

rock@radxa-e23:~$ sudo lsblk
[sudo] password for rock:
NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
sda 8:0 0 4.6T 0 disk
└─sda1 8:1 0 4.6T 0 part
mmcblk1 179:0 0 59.5G 0 disk
├─mmcblk1p1 179:1 0 512M 0 part
└─mmcblk1p2 179:2 0 59G 0 part /
mmcblk0 179:32 0 7.3G 0 disk
mmcblk0boot0 179:64 0 4M 1 disk
mmcblk0boot1 179:96 0 4M 1 disk
rock@radxa-e23:~$ sudo su - root
root@radxa-e23:~# lspci
00:00.0 PCI bridge: Fuzhou Rockchip Electronics Co., Ltd Device 3566 (rev 01)
01:00.0 PCI bridge: ASMedia Technology Inc. Device 1806 (rev 01)
02:00.0 PCI bridge: ASMedia Technology Inc. Device 1806 (rev 01)
02:02.0 PCI bridge: ASMedia Technology Inc. Device 1806 (rev 01)
02:06.0 PCI bridge: ASMedia Technology Inc. Device 1806 (rev 01)
02:0e.0 PCI bridge: ASMedia Technology Inc. Device 1806 (rev 01)
03:00.0 SATA controller: JMicron Technology Corp. Device 0585
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8125 2.5GbE Controller (rev 04)
root@radxa-e23:~# dmesg | grep pcie
[ 0.463780] rk-pcie 3c0000000.pcie: Looking up vpcie3v3-supply from device tree
[ 0.463895] rk-pcie 3c0000000.pcie: Linked as a consumer to regulator.2
[ 0.464310] rk-pcie 3c0000000.pcie: missing legacy IRQ resource
[ 0.464367] rk-pcie 3c0000000.pcie: Missing config reg space
[ 0.464417] rk-pcie 3c0000000.pcie: host bridge /pcie@fe260000 ranges:
[ 0.464508] rk-pcie 3c0000000.pcie: err 0x300000000…0x3007fffff -> 0x00000000
[ 0.464527] rk-pcie 3c0000000.pcie: IO 0x300800000…0x3008fffff -> 0x00800000
[ 0.464592] rk-pcie 3c0000000.pcie: MEM 0x300900000…0x33fffffff -> 0x00900000
[ 1.471655] rk-pcie 3c0000000.pcie: PCIe Linking… LTSSM is 0x0
[ 2.485327] rk-pcie 3c0000000.pcie: PCIe Link up, LTSSM is 0x30011
[ 2.485605] rk-pcie 3c0000000.pcie: PCI host bridge to bus 0000:00
[ 2.574166] pcieport 0000:00:00.0: Signaling PME with IRQ 101
[ 2.574648] pcieport 0000:00:00.0: AER enabled with IRQ 110
[ 2.575141] pcieport 0000:01:00.0: enabling device (0000 -> 0003)
[ 2.575990] pcieport 0000:02:00.0: enabling device (0000 -> 0003)
[ 2.576833] pcieport 0000:02:02.0: enabling device (0000 -> 0003)
root@radxa-e23:~#

@silverj

Sorry for the late reply. We will create a product-specific image for Taco.

Before we release Taco image, you can use the following command to replace the dtb,

wget https://cos.setq.me/rockpi/dtb/rk3566-radxa-e23.dtb
sudo mv rk3566-radxa-e23.dtb /boot/dtbs/`uname -r`/rockchip/rk3566-radxa-e23.dtb
sudo reboot

We have tested that HDMI and NVMe work.

Works for me as well. Thank you very much!

Was a proper Taco/CM3 image ever built? I had the same issue as above (no output from lspci, etc.). I tried loading the specified e23 image and while the board appears to boot (slow green flash) it appears that no peripherals are working (no HDMI, no network)

An update: The latest (20230401-0057) radxa-cm3-rpi-cm4-io Bullseye build seems to work.