Stripes on the screen

Sometimes at the beginning of the boot system, streaks appear on the screen. What is it?

Never seen this before, which OS image?

Whis debian, After that, the system boots normally, but these bands are alarming for me, although they are rare.
I wanted to test RAM, but memtester is not working
bash: /usr/local/bin/memtester: No such file or directory
# ls -al /usr/local/bin/memtester
-rwxr-xr-x 1 root root 12926 Nov 3 2018 /usr/local/bin/memtester

If it all works fine afterwards, don’t worry about it. It’s just one of those little computer things that happens sometimes.

On PC usually this mean speedy death video card.

… oops …I wrote the previous line 17 days ago, but did not send it.
And yesterday when power my pi4, I did not see the image on tv screen. Android was installed, blue led blinked normally. Loaded debian, no image, ok led. By ssh logged in, еverything ок except screen. Tried ubuntu, same thing. Installed debian on a new sd, and again tv doesn’t react at all to turning pi4 on.
I still have RPI3B. It works with both hdmi cables. Pi4 does not work with any.
I compared dmesg in before and now. Found the following differences.

[    1.750059] rockchip-drm display-subsystem: No connectors reported connected with modes
[    1.750787] [drm] Cannot find any crtc or sizes - going 1024x768
[    1.763006] Console: switching to colour frame buffer device 128x48
[    2.276580] rockchip-vop ff900000.vop: [drm:vop_crtc_enable] Update mode to 1920x1080p50, type: 11
[    2.308677] dwhdmi-rockchip ff940000.hdmi: PHY PLL failed to lock
[    2.425826] Console: switching to colour frame buffer device 240x67
[    2.081323] vdd_cpu_b: 712 <--> 1500 mV at 1000 mV
[    2.811962] vdd_cpu_b: 712 <--> 1500 mV at 825 mV 
[    2.085337] vdd_gpu: 712 <--> 1500 mV at 1000 mV
[    2.815390] vdd_gpu: 712 <--> 1500 mV at 800 mV 
[    2.093730] vdd_cpu_l: 750 <--> 1350 mV at 900 mV
[    2.823286] vdd_cpu_l: 750 <--> 1350 mV at 850 mV 
[    2.116229] rk3x-i2c ff3c0000.i2c: Initialized RK3xxx I2C bus at ffffff8009ca4000
[    2.117784] rk3x-i2c ff110000.i2c: Initialized RK3xxx I2C bus at ffffff8009ca6000
[    2.844063] rk3x-i2c ff3c0000.i2c: Initialized RK3xxx I2C bus at ffffff8009ca8000
[    2.845611] rk3x-i2c ff110000.i2c: Initialized RK3xxx I2C bus at ffffff8009caa000

That is complete nonsense.
It could mean a thousand different things, and NONE of them suggest a pending hardware failure.

For instance;
Display output is enabled prior to synchronization with the display, thus is in the wrong format.
Invalid buffer data being sent to the display.
Incorrect display parameters.

All possibilities are tied to SOFTWARE.

Maybe someone has ‘PHY PLL failed to lock’ error due to software problems. I have problems with hardware.
After unsuccessful attempts to get an image on the screen, I used rockpi recently only through ssh. And yesterday I tried to connect hdmi. And a miracle happened, an image appeared. The joy was short-lived, the image began to disappear periodically. I tried to press on the board in different places and got the job without losing the image. After that, from yesterday everything is ok. I’m now afraid to breathe on the board :wink:
Apparently my board is poorly soldered.

Yeah, that definitely sounds symptomatic of a cold or cracked solder joint. All it takes is one to cause countless problems. Sadly the only fix would be to reflow the entire board, a process beyond only the most hardcore hobbyists.