Static IP setup on wired nic port | rockpi4b-ubuntu-bionic

Hey guys,

Very simple questions, from a newbee to RockPi 4 using your image:
rockpi4b-ubuntu-bionic-minimal-20190104_2101-gpt.img

After flashing my MicroSD card using above mentioned image, everything works great !

  1. What is the Rock Pi (Radxa) official-correct way to set a static IP, subnet, Gateway and NS for the wired nic port (eth0) - not wifi ?

  2. And correct way to disable ipv6 on eth0

I’m asking since Netplan is not included, and there is a lot of different answers to be found when crawling the web.

If the answer is as simple as --> sudo netplan generate <-- and then just go the standard way from there, then perfect :slight_smile:

Thanx a lot.

/Flemming

Hey Guys,

Didn’t get any feedback :neutral_face:

If others have the same challenges, this is how I managed to solve it - with help from my pal Danial Bahl :wink:

Static IPv4
We found the nmtui interface simple and usefull.

Disable IPv6
check your current IPv6 address
ifconfig -a | grep inet6

Add the following to /etc/sysctl.conf - configuration file for setting system variables
net.ipv6.conf.all.disable_ipv6=1
net.ipv6.conf.default.disable_ipv6=1

Then reboot your RockPi.

Best rgz,
/Flemming

2 Likes

Hi, FleeDK

Thanks for sharing it. We are not network experts and now we leant something new :slight_smile:

Thanks for posting this @FleeDK. I couldn’t seem to get static IPs setup using the desktop GUI on the Debian image however using nmtui did the trick!

FYI the setup I got working was using the same static IP for wlan0 and eth0 with eth0 as a priority.