Ssh and vnc over usb to iPad for rockpi 4

Hi there,

I have a RockPi 4b running Arabian with Ubuntu bionic. I mainly use the board to contact it online over ssh/vnc/rdp to work in spyder and texmaker. Quite often the connection is slow however. Therefore I am thinking of changing the system such that i can just bring it on the road and connect it using a local network with the usbc cable outlet of the iPad and a USB port on the rockpi. The reason i would like to connect over a cable is speed and not having to use the WiFi so that both devices can still easily connect to a WiFi network for internet access. I have found many solutions where iPads are connected to raspberry pi’s. These solutions all have various forms, could anyone here please suggest me what the ‘ best’ solution would be in terms of ease of configuration and stability?

What i’ ve found so far:

I’m trying to create a usb0 network interface for my rockpi 4 for my bionic image to connect to.
I’ve found numerous guides for raspberry but they all involve configuration files that don’t exist.

I’ve also found a guide for armbian (which is where i’m on). This guide however also doesn’t work.

first of all the file /etc/modules is empty

whenever i reboot no usb0 interface will come online.

Sudo ifconfig -a doesn’t show a usb0 interface

Sudo lshw -C network only shows my wireless and ethernet connection.

sudo ifdown usb0 && sudo ifup usb0 yields:
ifdown: interface usb0 not configured
Unknown interface usb0

Im suspecting this could be a hardware thing, therefore i hope this forum could help me resolve this issue. I’ve also posted my question on the armbian forum, that forum is however not as kind as this one so i hope i have a better shot here.

I hope anyone can help me here

Thank you in advance.

Best regards,


Wow… There is much simplier guide, just do this

We have similar configuration for our Debian image, it should also works on the Armbian image.

Just the HOST is the ipad pro for you.

You need to modprobe g_ether to enable the usb0 device.

1 Like

That doesn’t work unfortunatly.

Thank you ill try this!

Too bad this doesnt work :frowning:

sudo modprobe g_ether
mofprobe: FATAL: Module g_ether not found in directory /lib/modules/4.4.182-rockchip64

Maybe i can just grab that contents from your image ? Or is that a bad idea?

If this feature works out of the box, it will be enabled and with next apt update it will be in Armbian by default. You can also help and prepare patch with changes to config. This way goes much faster.

1 Like