[Solved] Won't boot automaticly when power is provided

I bought 2 rockpi X.
One of them, when I provide it power, it has green and blue light (both not that bright). And in one second, the blue light goes bright, as if it is booting. Then in about 2 second, the blue light goes off, as if it is in OS.
But it is not. There are no output in HDMI. Short press the power button won’t do anything. I have to press the power button a little longer, about 2~3 second to get the blue light goes on and then bright again, then the OS boot.

Another one does boot once power is plugged, but after I somehow long pressed the power button to shutdown the OS, it also won’t boot automatically, just like the above mentioned one.

How can I make my RockpiX auto boot again?


Chinese here, can read Mandarin. Send in English mainly because there are lots of English posts here.

Solved. It seems to be some BIOS settings or status. I restore defualt in BIOS settings, it didn’t help. But after I remove the CMOS battery and wait for some minutes, both board will power on once powersupply is plugged.

Thanks for sharing. I too run into this issue.