[SOLVED] Unable to get in to Maskrom mode

Hi Guys,

Can somebody please help me with this. Because all the threads where people have the same problem, no solution is being given by the threadstarter. They find a solution and suddenly not share the solution.

I have managed to compile the devtools. Then this is what i get when i search for Memory Technology Device (mtdblock)

ls: cannot access ‘/dev/mtdblk*’: No such file or directory

I tried using Windows 10 in a VirtualMachine, there i get a device decriptor failed.

I have tried usb c <-> usb-c cable, i have tried usb-c -> USB-A. If you say, well the device is broken. I have bought 2 Rock5b 16GB…so both of them are broken?? I have been at it since last week.

Today i booted debian from micro-sdcard and was hoping that i am able to flash from within the OS itself, but also did not succeed.

I am btw trying to flash it so it starts from the NVME SSD.

Oke, i managed to fix it.

Apparently i have been misreading it almost for a whole week.

I was mixing " Step3: Boot the board to Maskrom mode" with " Option 1: Operate on ROCK 5B". But these headers in the wiki have NOTHING to do with each.

In reality how you should follow the tutorial is as following when using a external computer (Linux in my case).

  • Step3: Boot the board to Maskrom mode
  • Step4: Write U-Boot images to SPI Nor Flash or erase SPI Nor Flash
    • Option 2: Flash with Linux PC/Mac

The person who has created this wiki in this order…bro, you really did succeed in making me almost go mad, by putting this in the middle " Option 1: Operate on ROCK 5B". Very frustrating week indeed.

I used Linux and off course with the necessary troubleshooting to get to compile the flash tool (installing the dependencies). Afterwards, just follow the steps in the CORRECT order, then it is done within a few minutes.

Managed to boot Ubuntu on the NVME.

1 Like