[SOLVED] [SOLVED] Ribbon cables for M2 Extend board

At https://wiki.radxa.com/Rockpi4/hardware/M2_extend, one can read:

<<…The reduction of length, made it possible to move the FPC connector on the M.2 Extension board to the bottom side of the PCB. That is why there is also a new ribbon cable included in the package. The new FPC ribbon cable has contacts on opposite sides of the cable. ️Warning: Please don’t mix the ribbon cable of V1.2 and V1.4, they are reversed pin order. It may burn your ssd…>>


I ordered and received it in the last two weeks. It’s a v1.4 board. The box does contain two ribbon cables but they look absolutely identical to me (see picture below). Should I assume these are the right cables and one just gets two in case of accident with the first cable, the second is there as a backup?

TIA!

Dominique

Note: contrary to what the image suggests, the two cables have exactly the same length, the one on the right was just bent.

Those appear to be the longer FPC cables, which are 60mm long.

Yes, that’s their length. Are they the right ones?

Yes, either is ok.

1 Like

Hi Jack, TYVM for the timely reply.

I went ahead with the assembly and setup, it was uneventful. I love this little board. Neat and fast.

As another honorable member mentioned the HP EX920 does not show up (lsblk, fdisk -l, etc.)
I confirm.
On the other hand, the less stellar Crucial P1 does show up AOK.

Please update the latest u-boot.

sudo apt-get install rockpi4b-rk-u-boot-latest
sudo /usr/local/sbin/rockpi4b_upgrade_bootloader.sh

and type YES to flash it.

HP EX920 should be detected now. Here we have one 250G HP EX920, not working before and with this update, it’s working now.

Hello Jack,

/usr/local/sbin/rockpi4b_upgrade_bootloader.sh says:

root@rkpi4:~# /usr/local/sbin/rockpi4b_upgrade_bootloader.sh
Doing this will overwrite bootloader stored on your boot device. it might break your system.
If this happens you will have to manually fix that outside of your ROCK Pi 4.

You are currently running on different board:
ROCK PI 4B
It may brick your device or the system unless
you know what are you doing.

Type YES to continue or Ctrl-C to abort.

I pressed Ctrl-C.

P.S. Sorry for the delay but I was quite busy at work. I have an extra HP EX920 from another board which I can test. Just let me know if I can ignore the warning.

Just type YES, the warning is for the script executed by accident. Here we know what we are doing :slight_smile:

Hi Jack,

The 1TB version of HP EX920 is now showing up AOK. Mounted it, works with no issues. Congratulations on the fix. Case closed.

Best.