[Solved] Rock Pi 4C doesn't boot after imaging the eMMC

Hi, I just received my Rock Pi 4C with eMMC module today. I was able to get the debian desktop booted from the uSD then followed https://wiki.radxa.com/Rockpi4/install/eMMC to image the DietPi image onto the eMMC. Now my Rock Pi just flashes the Green LED a single time then hangs there with the LED on. If I remove the eMMC the uSD card boots again but with the eMMC in it just does not work. How can I replace the image on the eMMC if I made the mistake of not ordering any separate device to read/write the eMMC? I tried looking for USB readers here in Australia but all I found was readers that had a single plug for the eMMC instead of the double.

DietPi didn’t work for me either on RockPi4C. AFAIK, only using a product combo from Radxa as follows along with a SKK USB3.0 Card reader or similar such as:

Will allow you to flash your eMMC module.
Or getting this to avoid having to use 2 separate devices to flash your eMMC modules:

Some Odroid Users claim to be able to use their accessories to flash Radxa eMMC modules by leaving out the 30 pin connector(small one)which according to Radxa official wiki is for mounting purposes only and it’s supposessly Odroid compatible as well:
Would be nice if this can be confirmed by Radxa engineers here.
Odroid eMMC accessories here:

However, I’d strongly advise Not to do so to avoid potential damages to Radxa eMMC modules. I have those hardkernel accessories mentioned above since I’m an Odroid user as well but will not risk my Radxa eMMC modules testing that. Sorry to hear about your situation but you should just buy an eMMC flash reader/module writer from any official radxa distributors and wait.

Bummer it’s actually possible to flash a radxa eMMC module without using a eMMC to μSD card converter board by booting from uSD as long as the eMMC module is empty, because eMMC would always take priority over uSD to boot up first on RockPi4C.

How can I replace the image on the eMMC

Just write/dd another image to the eMMC with the eMMC->uSD adapter board.

I solved this by purchasing the adapter. It arrived today and now I have a bootable image installed. Still haven’t got DietPi working but that’s another challenge :slight_smile:

1 Like