[Solved] Radxa Camera 8M not listed in rsetup on Zero 3W

Hi, I’m trying to setup the 8m-219 with my zero 3w

I’ve installed the latest debian image, run rsetup, updated the latest overlays, and connected the two devices together:

the problem is i dont see [] Enable Radxa Camera 8M 219 on CSI0 listed in the available overlays (as mentioned here https://docs.radxa.com/en/compute-module/cm5/accessories/camera_8m)

am I doing something wrong?
any help appreciated - thanks in advance!

Activate this: radxa-zero3-rpi-camera-v2

hi @blondu thanks for the reply - can you please explain what you mean by activate?

should radxa-zero3-rpi-camera-v2 be accessible from terminal?

you should execute sudo rsetup and select

which is motioned in the page

Thanks @Peter.Wang, I did that however enabling the pi camera v1.3 does not persist.

i select this:

and then reboot, and after checking the selected overlays again, the camera v1.3 is not shown as enabled

Here’s what I see when attempting to view the camera with cheese:

You should enbale Radxa Camera 8M 219 by rsetup.

Thanks @Alvin, unfortunately the camera is not listed in rsetup

Does that mean the camera’s faulty?

Firstly, dumb mistake, I didn’t realise the space key actually selected/toggled items in the overlays menu. Pressing space on the highlighted overlay, causes it to be selected (as shown by *)

Once I did that on camera v1.3, I rebooted the device. The camera didn’t work.

I then tried camera v2, rebooted, and it worked. The Radax Camera 8M 219 seems to be recognized as a rasberrypi camera v2

Thanks for all who helped here

1 Like