Solution to axp288_fuel_gauge shutdown issue


Based on the information of /sys/class/power_supply/axp288_fuel_gauge/capacity, The battery is considered as continuously consumed using an MDY-11-EM Mi power adapter, which is supposed to support QC 3.0/2.0. I checked the wiki and QC 3.0/ 2.0 meets the requirement of Rock Pi X. I also tried other adapters which meet the requirement, but every adapter failed.

The problem is that if /sys/class/power_supply/axp288_fuel_gauge/capacity turns to zero, the machine will shutdown, you need to reboot it again to make the capacity to 100 again, then again and again.

Basic information

  • OS: Arch Linux
  • linux kernel: 6.7.5.arch1-1
  • firmware: install the radxa provided and linux-firmware in archlinux

Temp solution

I added a file named /etc/modprobe.d/rockpix.conf

blacklist axp288_fuel_gauge

then regenerate mkinitcpio

# mkinitcpio -p linux

Finally, you need to reboot the machine.


I tried to work on writing a patch for the kernel

1 Like

Today kernel team accepted this patch.

Based on Linus’s merge and patch, I think it will work at kernel 6.9

1 Like