Snap not working on Ubuntu

When I try to run a snap program, I get the error

rock@rock-5b:~/Downloads$ snap run firefox
cannot mount bpf filesystem under /sys/fs/bpf: No such file or directory

Not sure what debug information is needed, for now I have:

rock@rock-5b:~/Downloads$ snap --version
snap    2.57.6
snapd   2.57.6
series  16
ubuntu  22.04
kernel  5.10.66-27-rockchip-gea60d388902d

rock@rock-5b:~/Downloads$ stat -f /sys/fs/cgroup/
  File: "/sys/fs/cgroup/"
    ID: 0        Namelen: 255     Type: cgroup2fs
Block size: 4096       Fundamental block size: 4096
Blocks: Total: 0          Free: 0          Available: 0
Inodes: Total: 0          Free: 0

rock@rock-5b:~/Downloads$ stat -f /sys/fs/bpf/
stat: cannot read file system information for '/sys/fs/bpf/': No such file or directory

Anyone have any clue?

Probably will work on Armbian, but after installing it:
apt-get install snapd

Thanks for the reply. Unfortunately I’m not using Armbian, will try it out though. snapd was already installed when I tried to run, so the issue doesn’t seem to be that.

Issue is missing support in the kernel. I am almost sure Armbian has those options enabled. Ofc you can also build kernel on your own …

Thanks again for the reply, could you tell me which options need to be enabled, and how to I reconfigure the kernel with the new options?

What I did was upgrade the ubuntu version from focal to jammy. The kernel was kept the same. Snap worked in focal but not after the upgrade to jammy.

1 Like

I’m in exactly the same situation, using Rock Pi 5b, and upgraded to 22.04. Guess you can uninstall Firefox to remove it from Snap subsystem, and then install using a deb package from Mozilla. Not sure if it will keep open tabs and other settings though

I have Jost Rieks ubu gnome with FFox snap working great. It’s a very clean build. I also made room for KDE Plasma 6 on it and it’s super cool. Both run wayland too. Just need to get him to upgrade his build to Gnome 45 vs 42.9 But thats panfork holding it back. I have panthor running 45 on another card. :slight_smile:

Gnome 42.9 comes with Ubuntu Jammy so it would require changing a lot of repositories and dependencies. I doubt this will happen.