Slow usb3 hardrive writing


#1

Hi guys,

Just tried to create a NAS with an USB3 WD harddrive, I format the drive (2Tb EXT4 partitions). And try some copy (internal, samba, scp) it can do more than 12mb/s on copy.

I install debian (download radxa img) with default config (disk are automatically mount on /media/linaro). Does any had an external hardrive properly working ?

cheers


Slow network SCP, SAMBA, RSYNC copy on rockpi 4
#2

I also tested my USB3 disk setup according to this post:

I have the RockPi 4B 4GB with a 2 TB, 2" Seagate Barracuda Mobile. It is connected via an ICY Box USB3 SATA Adapter. The drive is formatted with a single ext4 partition. I mounted the disk, cd’ed into some directory on the disk and issued below commands several times. Here I used sudo because my normal user didn’t have write permission in that directory.

sudo dd if=/dev/zero of=./largefile bs=1M count=1024
sudo sh -c "sync && echo 3 > /proc/sys/vm/drop_caches"
dd if=./largefile of=/dev/null bs=4k

Results were around 125 MB/s for writing and 135 MB/s for reading.

With the disk connected to a USB2 port, I got around 29 MB/s for reading and writing.


#3

Thanks for the link

I did the hdparam and dd tests give some quite good result

DD test
itime sh -c “dd if=/dev/zero of=/media/linaro/02e9be1f-c05e-451e-99e7-1876eb6523d6/t bs=100k
count=1k && sync” ; rm /media/linaro/02e9be1f-c05e-451e-99e7-1876eb6523d6/t
1024+0 records in
1024+0 records out
104857600 bytes (105 MB, 100 MiB) copied, 0.421859 s, 249 MB/s

hdparm test
hdparm -Tt /dev/sdb

/dev/sdb:
Timing cached reads:   2256 MB in  2.00 seconds = 1128.56 MB/sec
Timing buffered disk reads: 308 MB in  3.01 seconds = 102.29 MB/sec

I have the same result when I copy from internal memory. it seams to be actually network issue my mistake I did internal copy test from an usb stick which is really slow.


#4

Investigate on some networking issue, Samba,scp,rsync copy is capped to 12mbps.