Setting up HARDWARE RAID with QUAD SATA-HAT (jms561 controller)

Sorry, I ask again:
With raidmgr_static I can only create RAID0 or RAID1?
To get a RAID10, I need to create a software RAID10 with mdadm out of 2 hardware RAID0?

Exactly. Only RAID1, RAID0 and JBOD are supported by this controller.

Hardware RAID and software RAID (mdadm) usually aren’t compatible with each other, you’ll probably need to get a replacement hardware RAID controller of the exact same make/model to reassemble your array.

RAID 1 is still ok because its just mirroring the data, so using it as individual disks is not much of a problem… RAID 0 is going to be a big issue because you cannot retrieve the data using mdadm if u used JMS hardware raid… you will need to buy another raid controller to retrieve the data…

thats why for longer term storage where performance may not be that critical, its best to go for software raid because you can quickly and easily move your disks from system to system and rebuild…

1 Like

@user12345 thanks for the guide. I tried the same setup, with only two drives and whenever I try to make the ext4 partition for the raid0 dev the command crashes

and dmseg has the following errors:

I power the rpi with a 12v 4pin from a PC psu and only have 2 drives connected.

What is wattage on Your 12V line? Are You connecting ssd or older hdd? 3.5?
Radxa recommends 12V 4A power supply. If there is too less power then disks die on spin up.

Hey @dominik, the psu is a Corsair TX650 and i use the 4pin floppy disk connector on the hat. I don’t use any other supply to power the pri or the hat (should I ?) The drives are 2 (out of 4 i want to use) 3.5 hdds that are powered through the hat.

Also noticed that the raid manager does not find the controller anymore:


Update to my issue and future stupid me.

As it seems I had a leftover sw raid0 and on top of that I was trying to make a hw raid 0, which worked but failed during the partition making. I removed the sw raid and created a hw one and now it works. The new issue is the very slow speeds which I will try to troubleshoot based on the other threads.

You should see both controllers if they are connected and have enough power to operate. I don’t know if that corsair produce needed power on that particular line, but it’s easy to measure with multimeter.
Software RAID relay on higher layer so this should not be the case here. Check out lsusb - You should get two controllers via blue-usb bridge and therefore jmb manager communication. Hardware RAID will cover pysical devices on system.