Set configuration for touchscreen


I want to use the Waveshare 5.5 amoled touchscreen with the Radxa Zero and Manjaro as OS.

Waveshare says in its documentations and in this video that there are some configurations required.

In Raspbian OS there are a few lines to add in the config.txt. But in my case there is no config.txt. Where do I have to add the config for this touchscreen?

I gave up as seemed to me that best option was to add it to the dtb.

I guess would be a good start as didn’t go much further but if you can can the EDID from some tool you have a head start.
I had the waveshare 4" which I dunno is a problem as it autoscales to 1080p but if that is what you want then it should if you can figure it out.
Maybe if you gave an EDID and posted it for manjaro saying support would be great with overlays maybe they might have the time to add some.

Raspberry is a pecular beast as the system loader is the Video DSP and the Arm hardware sits ontop so its not the same really but the nearest to config.txt is a config of defined overlays, in fact think that is what it does but just in a different way.

I might have a go again with this 4" Waveshare but hoping someone a little more conversant with the required overlay might jump in.

@stuartiannaylor I tried it with following 10 inch touchscreen and this works. It also works when I connect a usb cable for touch and the touch functionality worked fine.

Yeah I got portrait mode working it was landscape that didn’t go well. Also found the scaler to be problematic.

In my case nothing is happening in the touchscreen. It stays black.


I’m also trying to get the touchscreen working with my Radxa Zero!

and I have the script that should go into the “config.txt”. After some research I got a few solutions by comparing the Raspian and Ubuntu System, I willl test them all and report back.

Best Regards

1 Like

Does the entire screen remain black, or do you mean that the touch doesnt work?

I mean that the entire screen remain black. It didn’t shows anything

The touchscreen prob needs i2c enabling but there is no config.txt equivalent.

Usage: add item “meson-g12a-i2c-ee-m1-gpioh-6-gpioh-7” to “overlays=” line in /boot/uEnv.txt

I think that is the right pins but check the gpio

No that doesn’t seems to work. I use Manjaro on the Radxa.

I connected my screen to the Radxa and it worked out of the box. (I’m still looking for a slimmer 7" screen, if someone has cheap solutions that would be very helpful)

I was googling on my way home one day and I found a few solutions, but I can’t find all the links that I saved on my phone)

I would look for “touchscreen”, “hdmi on ubuntu not working” “configuration”

This two keywords could help: (I think those two are the things that are somewhere on my phone)


Here a similar question:

“config.txt on ubuntu”

Generally you should find/look for the config file somewhere on Ubuntu(every os has it), just try asking the Ubuntu community, they are the specialists.

I hope you already resolved your issue,
Best Regards.

I solved my problem by using a other touchscreen. I also asked the Waveshare support and they told me that it is not supported for the Radxa Zero. But I can test it if I can still find it out.

I would look for the specific Ubuntu config file that people use to calibrate the screens, touch screens, audio over HDMI, ect…

I was already prepared for the worst and I must admit that I had pure good luck with the screen.(I would love to share the link, because it has decent resolution, adjustible brightness and decent touch responsiveness). Can I know what Screen did you bought? I will post the amazon link as soon I come back home. It would be interesting to compare what is compatible out of the box with the Radxas. (I’m pretty sure I will order some Radxa Zero 2 as soon as they come out)

I use following touchscreen:

The cool thing is that it is connectable with speakers. I also bought the recommended speakers and it works fine. The function buttons are also cool but not as good for me because I want to make all screen configurations in the software not with buttons.

Hi. Any progress on that 5.5 amoled with radxa zero? I want to use it with Dietpi but no config file.