RZ Boot Helper won’t run

I’m trying to follow the instructions here to install on my Zero, but it never gets past “ - - start run - -“


I’m following the Windows instructions. I’ve loaded up the factory-loader.img, but when I click “run”, all I get is the “start run” message, the run and erase buttons become disabled. It never goes any further than that.

Hello MarkWalsh,

Can you try a different cable and a different USB port?

1 Like

Thanks for the help, I originally had it plugged into a usb hub, so I grabbed a different cable and plugged it directly into the computer.

The first time I got it to run, and it did get to the “run done”, but I got several crash messages immediately afterwards (Isusb.exe has stopped working) and since then I can’t get it to load. “Not detected” comes up instead of “Maskrom mode”. I unplugged it and started it up while I have the Boot Helper program running, and I got the crash message again as it powered up.

I’m very need to this, I have a few Raspberry pi’s , but I only have used them with an SD card, so I’m not familiar with this procedure.

It looks like the lsusb.exe is not compatible with your computer. What version of your system do you have, I would like to test it.

1 Like

I’m running an older system, I have Windows 8.1 pro on this computer.

I restarted the computer, and was sble to load it again. It ran without any crash errors, but didn’t output as much as previously. It did end with

Running at 0xfffa0000…

Would that indicate that the previous action was successful?

Or you can manually install pyamlboot and run it.

  1. Download Python3
  2. Install pyamlboot via pip
  3. Run it on the cmd

    python3 boot-g12.py rz-udisk-loader.bin

It doesn’t look like it worked. Not seen the [BL2 END]

thanks again, I’m not familiar with python, something I’ve been wanting to get around to.

I have a laptop running windows 10, I’ll try it on that later today. Maybe I’ll have better luck there. I have another PC that I can try, I just have nowhere to set it up without taking my production computer offline, so if the laptop doesn’t work, I’ll see if I can try that over the weekend. I also have 2 macs, but I’d prefer not to use those as our Mac IT guy is more strict with loading software on those.

It worked on the laptop running Windows 10. It’s an old machine, so it’s excruciatingly slow, but i got through all steps except for erasing the memory, but I was able to load Armbian, and I’m getting the startup screen now, it’s taking a while to load, so I don’t know if it’s running properly, but at least the first steps worked.

Thanks for all of your assistance.

Edit: Success! Armbian is up and running!