RockPiS is 1Ghz Max not 1.3Ghz

rock@rockpis:~$ lscpu | grep MHz
CPU max MHz:         1008.0000
CPU min MHz:         408.0000

Is there any reason it seems to be underclocked to 1Ghz?
Presume there is a 1.3ghz dtbo that could be provided that maybe could be added and we just rename and swap between the 2?
I presume one of those little Pi heatsinks will do no harm.

There be a dtbo/dts in this here zip of 1296000

Not me as stolen from those wonderfull people at Slackware
rock@rockpis:~$ lscpu | grep MHz
CPU max MHz: 1296.0000
CPU min MHz: 408.0000

1 Like

Ps I did some benchmarks running @ 1296000 and seems stable and doesn’t throttle.

I used the Pi benchs of
Where the original is

But also if you download this one it has the benchtexts from the last RockPiS in it so you can compare before you run.
RockPiS trades very well with a Pi3B+

Benches are what they are but it gives you a metric to the RockPiS

1 Like

The latest version, 4.4.143-48, of kernel supports 1.3GHz.

1 Like

Not sure what you mean by support as with the Ubuntu version the DTS sets the max frequency to 1Ghz, its either clocked to a max of 1.0ghz as it was or it now has a DTS change.
Didn’t check the Debian version.

So slightly confused by supported by the kernel as the kernel doesn’t set the CPU clock the dts in /boot/firmware does and with the version you mention on ubuntu its 1.0Ghz.
In fact thinking about it, it prob was the Debian version not ubuntu I tried as its Ubuntu 20.04 that I have been using with my Pi’s.

Bump: I’m on your Ubuntu and there is no kernel 4.4.143-48.

As of today, the latest kernel is:

rock@rockpis:~$ uname -a
Linux rockpis 4.4.143-47-rockchip-g495ff574976c #1 SMP PREEMPT Tue Apr 21 01:38:40 UTC 2020 aarch64 aarch64 aarch64 GNU/Linux

and speed is still limited to 1 GHz:

root@rockpis:~# lscpu
Architecture: aarch64
Byte Order: Little Endian
CPU(s): 4
On-line CPU(s) list: 0-3
Thread(s) per core: 1
Core(s) per socket: 4
Socket(s): 1
Vendor ID: ARM
Model: 2
Model name: Cortex-A35
Stepping: r0p2
CPU max MHz: 1008.0000
CPU min MHz: 408.0000
BogoMIPS: 48.00
Flags: fp asimd aes pmull sha1 sha2 crc32

Yeah I thought the same you just have to copy the dts from the first post and paste over existing maybe keep a backup of the orig :slight_smile:

That file is not available for download (error message).

And, there’s no 4.4.143-48 kernel :frowning:

Try now, think I deleted when supposedly in kernel release

1 Like

Will have to study what to do with these files (never used a device tree before), but now I downloaded them. :slight_smile:

/boot/firmware copy the dtb dts is just the original text version you make the binary with.
But backup yours first.

PS that is my memory but in that area you will see all the other dtb files there and one with same name

1 Like

Thanks! Will come back with lots of benchmarks and power draw figures. :slight_smile:

Suppose you haven’t worked out the microphone wiring yet have you? :slight_smile:

That was not me…?
I’m fighting with RAM, no mics. :slight_smile:

Is back up it has my test results in it and the bench software

I’m now running @1.3 GHz, Userspace governor with fixed frequency (needed for comparison).
Impressive efficiency.
7Zip parallel benchmark draws only 1.6 W (drops to 1.2 W @ 1 GHz), for 2100 MIPS average.
My previous efficiency champion, the Odroid C0 @ 1.3 GHz, draws 2.4 W for 2550 MIPS.

1 Like

They are added to Radxa APT bionic-testing and buster-testing twenty days ago.

Now the latest version of ROCK Pi S Kernel, 4.4.143-49, are also added to Radxa APT bionic-stable and buster-stable.

Yeah when you bump to 1.3Ghz the A35 makes for a pretty impressive Pi3.
I stuck some heatsinks on mine, dunno why :slight_smile:

1 Like

Sorry, the “testing” repository you are referring to is not present in the official image I downloaded.
Good to know I can now get 4.4.143-49!

Check file /etc/apt/sources.list.d/apt-radxa-com.list.

$ cat /etc/apt/sources.list.d/apt-radxa-com.list 
deb buster main
#deb buster main

By default, the “buster-testing” line is commented. Thus you can not download packages from buster-testing repository.

That’s what I said: with the official image, I had no access to this newer kernel.
I did not know about the need to uncomment that line. Maybe you could update the FAQ?
The suggestion in the other thread about a way to reclaim 62 MB of memory should also be in the FAQ, IMHO.