Rockpi4b - Manjaro 19.10 xfce boots from M.2

Hardware : Rockpi 4B
M.2 : HP SSD EX900 M.2 250GB

kernel 5.4.2

After updating the spi with the following statements :
sudo rkdeveloptool ld
sudo rkdeveloptool db rk3399_loader_spinor_v1.15.114.bin
sudo rkdeveloptool wl 0 rockpi4b-uboot-trust-spi_2017.09-2681-geb41d9a6ce_20191104.img
sudo rkdeveloptool rd
writing the img to the M.2
Boots without sd card

Thanks for the info. Could post some desktop disk usage of Manjaro to show to other users that it actual work?

Some screenshots :

Got no wifi working yet, sound only hdmi.

1 Like

Please, could you show more in detail how to perform this procedure?
For example, which manuals did you follow to carry out these commands.
Or is it simply a matter of booting from sd with manjaro and executing these commands?

@aguapi, I just followed the wiki ( to update the spi, make sure to use the latest uboot-trust.
I then used etcher to write the img to the nvme drive using a HDD enclosure from aliexpress : HDD Enclosure/Case/Box M.2 SSD Enclosure M.2 PCIE NVME Enclosure M2 NVME PCIE USB3.1 Type C Hard Disk Case Hard Drive Enclosure, but if you have a large sdcard (min 16gb) it must be possible the write the img via dd.
Manjaro 19.12 KDE also works. (no wifi)
Manjaro 19.10 XFCE works (no wifi)
Manjaro 19.12 XFCE works BUT NO ETH and NO WIFI

1 Like

For Manjaro 19.12 Xfce network not working, can try the latest image (19.12.1).

If already downloaded 19.12, can try workaround:

Thanks for the replies. I already tried, from sd and nvme card and it doesn’t start. the blue and green lights turn on, but the screen is black. so I guess there is some problem with spi.

Not all nvme drives work see fac :

HEllo: I am reading the instructions of spi-install. I have two questions:
1- I had already done this procedure with the method mtd. Now, do I have to delete the old one first or proceed to spi-install directly?
2- This part of the instructions gives me a question: Remove the cable and disconnect PIN23 and PIN25. When you say “remove the cable” does it refer to the cable that connects pin23 and pin 25 or does it refer to the power cable? Because then it says “and disconnect”, that is, remove and disconnect: is it a movement or two movements? Sorry, but I’m afraid to connect rockpi to the pc and burn something.

I installed on top of the old spi.
just disconnect pin23 and pin25 not the powercable.

1 Like

The side of the USB cable which goes on the PC, can go on any USB port without distinction? My Linux PC has 2 rear 3.0 ports and two free front 2.0 ports. I don’t know if any of them qualify as otg.
sorry if my questions are too basic. but I’m pretty scared to connect the rockpi board to the pc.

You should connect the top usb3 port on the rockpi4 with the usb3 port on the pc with a usb3 cable like the picture below.
I bought mine from aliexpress : Ugreen USB to USB Extension Cable Type A Male to Male USB 3.0 2.0 Extender for Radiator Hard Disk Webcom USB 3.0 Cable Extension
Hope you can sort it out.

Hi, I tried several times and always got the same result. My cable is a USB 2.0 male male

This is mostly like a usb signal issue. Try to connect to the back port of motherboard, for laptop, use the USB port on motherboard side, not the other Internal extended side.