Rockpi will not boot


#1

HI
I cannot get the rockpi to boot am using a 32gb microsd with latest android powered by an adaptor with QC 3 port with 5v 3a or 9v 2a or 12v 1.5a The type c cable is rated to 3A 60w

i don’t receive any video output at all and also note there is no power supplied to the usb ports as the mouse laser light does not power on but works fine on other devices. The green LED lights on the motherboard but that’s about it

Steve


#2

Hi Steve

If you have the USB to TTL debug cable, you can send us the booting log.
But I guess not everyone has it. Refer: https://wiki.radxa.com/Rockpi4/dev/serial-console


#3

For me this is my first foray into pi type computing so i don’t own a debug cable


#4

What boot device do you use with which image?
SD-card? eMMC?
How did you write the image to the device? You do power it with the usb type c? Is there any LED lighting up?

Maybe show a picture of how it’s connected and so.
I don’t know how much experience you have with computers, that’s why I ask these simple things.

Greetings.


#5

My Rock Pi 4 board do not boot. No output in mointor (or TV). No power in USB port (both USB2.0/USB3.0).

The details are :
ROCK PI 4B v1.3
SanDisk Ultra (HC1) 32G sdcard tried (android/debina/ubuntu minimal tried)
32G emmc5.1 (android/debina images tried)

Connect the debug interface of the 40pin header to a 3.3V USB (power by USB port it self) to serial cable to retrieve the debug message. But not a single character is found in the terminal :
pin 6 (GND) <–> GND of serial to USB
pin 8 (TxD) <–> RXD of serial to USB

The 5V (~5.01V measured) and 3V (~3.3V measured) of the 40pin header show that the board is already properly powered. The adaptor is Xiaomi 36W QC3.0 compatible.


#6

Hi, Orion

This issue might be related with Xiaomi adapter: PD power supply conflicts with serial console?

Could you try with a normal usb 5V adapter? It can at least boot. Please also connect the USB to TTL to serial console. Make sure set the baud rate to 1500000 and don’t connect the red 3.3 wire, picture as below:

https://wiki.radxa.com/Rockpi4/dev/serial-console


#7

Another tips to identify if the CPU is alive is, power on the board without sdcard or eMMC module. And plug the upper USB3 port to PC with USB 2.0 or 3.0 male A to A cable. The PC should show the rockpi device with lsusb.

   Bus 003 Device 005: ID 2207:330c

#8

At first, I connect the HDMI, power input (USB3.0 type C), storage (sdcard/emmc) with different images to the board without the serial cable. The board do boot. The LED is up. The HDMI is connected directly to the monitor, not going through any HDMI hub/switch.

After trying different images, the board still cannot boot. Then I connect the the serial cable, trying to get the messge. But not a single character can be found.

I also tried another adaptor capable of 12V 1.5A. But still no output.

The case your referred is different as the LED is not on in that case which indicated the the adaptor might be an issue.


#9

I tried already with a normal 5V power adaptor. Just connect the sdcard and HDMI (no serial cable).
Still no signal comming out from the HDMI port.


#10

Please contact your distributor for a RMA. We will check what’s wrong with it.


#11

Did you wait enough time to show anything on the screen? It takes over a dozen of seconds…


#12

Please describe the EXACT procedure you used to write the image files to the emmc / usd


#13

I usually wait for around 10s but sometimes 20s more. The software I use is the version 1.4.9 downloaded from the balena-etcher website (balena-etcher-electron-1.4.9-linux-x64.zip). The image is validated by the software write process.

I also use sudo dd if=XXXX.img of=/dev/sdb bs=1M conv=fsync
sync
sync

Nothing on the screen in HDMI. Not a single character on the DEBUG_TXD. (Baud rate is set to 1500000 8N1 no flow control, also tried with 115200, 9600, …).

I also tired to insert the 3.3 USB to serial cable (with have a LED on it) to the USB2/3 port. The LED of the cable is off which indicates that the both ports are not powered.
I am asking for the RMA to check in details.


#14

I am now having the same problem - my board is not booting for Ubuntu or Debian, with SD card, I tried different adapters, different monitors, and the LED glows but the serial debug console doesn’t show any output. I was using this same board earlier for programming and other work, with the Ubuntu 18.04 Server image and it was working fine, but all of a sudden it failed to boot, both this image and after reflashing with Debian.


#15

Have you tried another sd-card too?


#16

This seems an issue. It’s just “all of a sudden”? Any notable unusual things happened?


#17

Sorry for the late reply. I normally use the device with the official power adapter provided by Radxa, but I need to use this in a car, so I took it in a car and connected it via a normal USB cable to an adapter in the vehicle, and later to a cigarette lighter USB adapter. It doesn’t seem like this would cause an issue (in fact I did this with a Raspberry Pi also, and that continues to work fine). This is the only “unusual” thing I have done with it. I am going to order more of the boards soon, as I had only one and was using it for all testing.


#18

I had the same problem yesterday. RockPI hung and did not start any more from eMMC module. No output via hdmi. Using a sd card I was able to boot. Checked the eMMC partitions. These were ok. Tried to boot from eMMC again and it worked without having anything changed knowingly.

Actually I was able to ping the device! But no hdmi output, no ssh access, no log file entries.


#19

Same problem for me. RockPI freezed after few days working perfectly with ubuntu minimal server. Now I´m not able to boot from eMMC or SD. I’ll try to check der serial output the next days…


#20

so for me, the problem was the emmc also… after removing the emmc and working with sd everything seems fine!