Rockpi doesnt boot when a serial device is connected to uart2

I am having the following issue with the rockpi4b, I have configured the rockpi4b uart2 port to allow for serial communication. However when I have a device connected then the rockpi does not boot. The lights come on but they don’t flicker like they do during an active state.
It boots if the ground pin is not connected.
What do I need to do to get it to work with a serial connection?

I had a similar issue with the Radxa Zero not booting when I had a serial console attached but worked if the ground was disconnected. It was driving me crazy. It turned out to be the power adapter. Yup the power adapter. I was using a recent cell phone power adapter that is rated 5v @ 3a and 9v @ 2a. On a whim I bought the power adapter listed as an accessory for the Radxa Zero in the online shop. The specs for this power adapter are 5v @ 3a, 9v @ 2a and 12v @ 1.5a. Using the new power adapter every worked as expected. It booted with or without the serial console attached. I can’t say for sure if this is the same issue, but I think it is worth a try.