RockPi 4 C+ OSes Support

I have three brand new Rock Pi 4C+/4GB to run Linux on. I already had one with Android running without issues.

The idea was to run either Flatcar (would be best) or DietPi, as these are to run Kubernetes cluster on top of those. Haven’t found a way to run Flatcar but I don’t care too much (unless someone already found a way ?). Took the DietPi image, but it just does not boot at all. Nothing is happening. No error, no nothing.

Then, I checked on other images. The only one I’ve been able to boot is Armbian (specifically, this one: Armbian_22.11.0-trunk_Rockpi-4c_bullseye_current_5.15.76_minimal.img). Funny thing is that the blue (drive) LED does not show. I then tried to run these other versions of Armbian (Armbian_v22.05.2_Rockpi-4cplus_bullseye_current_6.1.33.img and Armbian_23.5.1_Rockpi-4c_bookworm_current_6.1.30.img). Bookworm gives me the same result as DietPi aka nothing at all. Bullseye 6.1.33 shows the blue LED flashing regularly, but never leads to a boot sequence.

At this point, I need to make some progress. Any success with DietPI of the most recent Armbian (though I’d prefer DietPI) ?

P.S. Before someone asks… GPIO pin 23 and 25 are connected together

< GPIO pin 23 and 25 are connected together> Curious why?
I tried most of the images you speak of, they worked to varying degrees for me. They booted.
Some distros I noticed like to default to a different hdmi output.
If no output at all, the only way to see what is going on is to connect to the serial console and watch the boot process via serial. I use a TTL to USB adapter and putty.

pin 23 to pin25 connection. Taken from some posts where it was instructed to do so to avoid SPI flash stuff and boot normally. As I had some issues when working with my first RockPI 4c+, I ended up hooking them together and end up in a working situation. Should try in this other RockPI to see if that makes a difference to have them connected together or not.

Will check the serial console thing. Pretty sure I have a TTL-to-USB cable somewhere.

Thanks for the tip

As far as I know, unless you solder on your own spi flash chip, we don’t have one on the 4c+ but maybe there were some dev boards with one? Anyway, I don’t think you need those pins connected. Lastly, if you connect the tty, remember 3 volts. NOT 5v

Please note, a 4C is not the same as a 4C+, so at least fir Armbian you took the wrong image

That said, armbian with a 6.x kernel runs fine on my 4C+.

I haven’t tried the most current, do you know if the camera is working on that yet?

Hi, my Rock 4C+ runs DietPi with no issue (well…the only problem I have is that I’m unable to read the board temperatures for now) - I followed this guide and the “getting started” part etc… no problem so far .
PS : I never connected pin 23 and 25

Christian already found out that Armbian runs with no issue. Dietpi is yet another re-branded version of Armbian OS with added bloatware. In case you want to make your own Diet or Fat pi OS, without any suspicious spaghetti scripts you don’t want to gave root permissions, try Armbian build framework.

1 Like