RockPI 4 B will not boot

I just got my rockpi 4b with emmc module. I have a 128 GB micro ssd, which I flashed with stock image found on site. Flashed using etcher.

This is the ssd card

and this is my USB charging cable.

I also have a USB C output from my laptop docking station.

  1. emmc connected but no ssd : I see a message on my monitor telling me to install os on emmc

  2. emmc conneced and ssd : if I use AUKEY charging cable, green led goes on for two seconds, goes off, then goes on again and is solid - no flashing. Screen is black. If I use the laptop docking station, the green led goes on and stays on - does not turn off. But screen is still black.

  3. With emmc and ssd removed, and rock pi cabled to my pc using charging cable to usb c, when I run lsusb, I don’t see any entries for rock pi.


If you want to boot from SD card, try removing the eMMC first.

The boot preference is SPI > eMMC > SD.

If multiple boot devices are present, it can conflict.

Thanks @aaditya for your reply. I did remove the eMMC, but the problem still happens.
Do you know why the green led would blink once for one cable, but not for another one ?

It might be a power issue.

The wiki says:

  • The ROCK Pi 4 is powered by Type-C port and has a wide range of input voltage, from 9V to 21V. The Pi supports USB Type-C PD 2.0 with 9V/2A, 12V/2A, 15V/2A and 20V/2A. Besides, the Pi supports QC 3.0/2.0 with 9V/2A and 12V/1.5A.
  • The Type-C cable used needs to support data communication.

Maybe the longer Aukey USB cable supplies less power initially, so the power light blinks on / off in the beginning.

Post the which image link too which was flashed.

Hmm, wiki says it should work.

Will test it tomorrow and confirm.

Re-reading the docs, one is supposed to use a USB to USB male cable to plug top USB 3 port on Rock Pi to USB port on PC. Not USB C Rock Pi port to USB. :slight_smile:

For me power led (green) switches on after connecting power and stays on. Once the kernel is booted up, the status led (blue or red depending on Rock Pi version) also starts blinking.

I think its simply a case of flashing the right image correctly, since it works with out of the box eMMC card.


said you use AUKEY cable in one case, but you did not say what charger you used. If it is an intelligent charger with USB-PD, it can provide different voltages, and not only 5V. I have not yet tried such a charger, but maybe when the charger changes from 5V to the highest negotiated voltage (9, 12, 15 or 20 i think), then there is a short interruption of power and thats what you see as an interruption of the light on the rockpi

If you connect the AUKEY cable to a USB output or charger that only supports 5V, then there is a good risk that the cable will not be able to deliver enough Amps to power the rockpi and possible USB devices connected to the rockpi. At least its been my experience that longer USB cables always suck to pass through power. You could buy a charging-only USB cable, that would typically be better, but even then i was disappointed in some product, especialyla t 2 meter length. Best solution is really to use a USB-PD capable charger that delivers at least 12V.

Have you ever managed to get the rockpi up and running in before ?
Is your rockpi a v1.4 with SPI installed ? E.g.: i am not sure that all the wiki described details have been updated to reflect what a v1.4 rockpi with SPI does.

Thanks again - I did get it running finally. I think it was a combination of wrong power cable, and issue with emmc - With unflashed emmc installed + micro ssd, the board will not boot. With emmc removed, it will.

Thanks, @raidboy. I used the USB C cable from my laptop docking station, and also removed the emmc card, and it now works.

I use the GPIO pins to power up the RockPi with a dedicated 5volt/4amp power supply. Works well with all the attachments I have on the unit. I never did get it to boot up with anything but the Debian os using the onboard memory module and still no blue tooth function. Otherwise it works good.