Rockpi 4 4GB wont boot up after flash

Required Information

  • DietPi version |
  • Distro version | Buster
  • Kernel version |
  • SBC device | ROCKPi4-ARMv8
  • Power supply used | 5V 3A
  • SDcard used | SanDisk ultra 64GB

Additional Information

I cant boot up after a fresh flash to the SD-card
I used Rufus, Win32DiskImager, and Etcher
I dont get a picture when i connect the device to a monitor via HDMI (not with an adapter)
I dont see the device in my router when its connected to my LAN

Steps to reproduce

Flash rockpi4-debian-stretch-desktop on SD-card. Boot up and apt-get update && apt-get upgrade
(i dont know if this is the problem:) Type “y” at the question:

“Step one: upgrade bootloader on SPI Flash
One boot device, SPI Flash, is found, would you like to upgrade bootloader on it?
The installation would cost about seven minutes.”

shut down the device

take out SD
flash Dietpi from to Sd
put it back and nothing works

Expected behaviour

Dietpi should boot up and show up in my router or show something on my monitor

Actual behaviour

The green LED lights up constantly
no picture on monitor, not showing up in router.

Extra details

It worked a few days ago. Then i used rockpi4-debian-stretch-desktop with the SD-card booted up and upgradet the bootloader on SPI Flash. I reflashed Dietpi, nothing works now.

I still can Flash rockpi4-debian-stretch-desktop and it will boot up, but dietpi wont.

Here is a workaround… But its strange anyway.

This worked too with an fresh installed dietpi image:

If the SPI flash already contains a bootable bootloader, you need to disable the SPI flash at boot time by shortcut the SPI1_CLK to GND. Use wire to connect PIN 23 and 25 . Checkout the Pinout .

Check the picture on:

It’s weird because i have the same issue but with the Debian provided by Radxa.
Now i cannot boot armbian for example if i don’t disable SPI. I have tried to empty the SPI but it’s the same.
Any ideas ?

Hey there :]

Hummmm, there is two times the option to update a bootloader. First the SPI, second some kind of uSD card. What bootmedium are you using? An micro SD card, an M.2 an USB-Stick or an eMMC?

Was there a error message while deleting the SPI-Flash? You can Flash the SPI-Flash via an Linux PC. Probably, I was kind of too stupid for that, because strangely enough it didn’t work for me.


I’m using a eMMC. To empty the SPI i have followed this : (section Erase images on SPI).
But in fact my problem seems to be the armbian image with kernel 5.4. Now there is an official message saying that this kernel is broken.
With armbian kernel 4.4 everything works fine.

It was fixed at least at the sources level. Version 5.4.10 and up should be fine. Also slow boot problem is still present … so you have to wait 30-60s before you get something on the screen.

But remember that this kernel is not near to the functionality and maturity of 4.4.y

Ho nice ! I didn’t see this commit. Thank you for the information :slight_smile:
I will wait for a new armbian image then.
My rockpi4 will be a kubernetes node, so i don’t need a lot of functionnalities… just to be stable :slight_smile:

That humble idea is one if not the most expensive problem to solve :wink:

For you kernel 4.4 will be more stable ? Since i’m a k8s user, i would like to have a recent kernel.
Do you know when a new image will be available ?

Its a matter of discussion / perspective. Mainline kernel has its own path and RK3399 support is getting in step by step from the kernel where support for this hardware was developed by Rockchip and reused by Radxa to adjust their changes and custom features which differ from a reference design. In modern kernel, mainly developed/ported by community, not all features are supported and not all features are considered matured. This information is changing all the time and perhaps my perspective is already outdated - being up2date is very expensive. But in general, features simply can’t be matured because they are not long enough in the kernel. CI and automatic testing - if exits on this hardware - can only spot basic things … or problems are already known to people that deal with but nobody has found time to fix them.

New image can be build at this moment but this means nothing. If you are asking for what works and what not, what is matured and what not … download image, start collecting information (daily) and start providing this service? I can’t afford doing that, perhaps you do.

Thanks for your answer. I will try a new image and report issues if i have problems :slight_smile: