Rock4 SE uart2 not working

Hello all!

I recently purchased a Rock 4 SE to develop a project.

To do this, I need to connect a device to a UART.

I have tried to follow several guides that I have found on the wiki and in this forum, but I cannot make it work.

I used rock-4se_debian_bullseye_kde_b33.img
Then, this tutorial: Common interface with Kernel 5.10

I also install minicom to test the device, but it doesnt work (not responding to any comands).

Then, i search at this forum and found this post: Use TX/RX pins8-10
I followed the steps, but I had to put the key to hand, used this steps:

But i get some erros with rockchip-fstab:
Unable to locate package rockchip-fstab
Unable to locate linux-4.4-latest
Unable to locate rockpi4b-rk-u-boot-lastest

Please, help!

We recommend using rsetup to open that overlay in kernel 5.10, you can refer to this
Device Tree Overlays, and I will update Common interface with Kernel 5.10 later.

Hello @Nasca
I also tried rsetup to open the overlay, but it doesnt work.

The first link you provide isnt working.

Thanks for help!

Is there a ttyS2 device under /dev/ after you enable uart2 overlay?

if not, please provide the download link of the image for me to confirm the situation.

Yes, there are a ttyS2 device listed.
Link to image im using

But i think this device was always there.

If i used rsetup to activate overlay for uart2 and then go again to view overlays, it isnt marked as active. Even after a reboot.

Anyway, all times i try to activate it, i check if is working usin minicom to send some comands to the “hat” im using and i dont get any response. The hat is working because i already tested it on Raspberry Pi

please try the following command before you send, or you can set other baud rate、cs:

stty -F /dev/ttyS7 speed 115200 cs8 -parenb -cstopb  -echo

or you can use libmraa 、wiringX to use uart.

I tried that comand, result:

Then i test UART2 with minicom without result.

Now i’ve tried with mraa. Used the example provided “”:
ValueError: Error initialising UART

UART2 should be occupied by FIQDebugger by default. Please check if you have /dev/ttyFIQ0 available.


/dev/ttyFIQ0 is not available (not listed)

How can i solve this?

@Nasca Please retest this issue.

I have the same issue, cant get it to work.
Also any communication on the port will stop it from booting it seems.

Tried with and without UART2 overlay selected in rsetup.

removed console and FIQDebugger from

any time i try to access ttyS2 i get permission denied