ROCK pi4安装opencl报错

按教程安装opencl驱动后,clinfo,报:ERROR:The DDK is not compatible with any of the Mali GPUs on the system.The DDK was built for 0x860 r2p0 status range [0…15],but none of the GPUs matched:
Number of platforms 0。
之前所有安装步骤都没有报错,请问是啥原因,谢谢!

教程哪里来的,openCL驱动哪里来的?