Rock Pi S 麦克风测试

请问Rock Pi S 板载麦克风输入该如何测试连接?(MIC1~MIC8改如何连接?是使用数字或者模拟麦克风?)
现在使用aplay 可以正常放音,但是arecord无法录入音频。

Codec is index 1
so -Dplughw:1
arecord -h for options

Mic 3,4 is a good question also what ADC_KEY_IN1 is, is another good question, but not needed.

I2S_0 also works but also that loses the lines out as presume it now goes to the I2S output.

I am trying to work out if the VAD only works with I2S or PDM but haven’t a clue how to enable or use VAD so no bother.

@stuartiannaylor Thanks for the reply.
The cmd was :
arecord -D plughw:1,0 -d 5 -f S16_LE -c 1 -r 16000 tmp.wav
But have no sound record!
The microphone was connect to MIC8P & MIC8N.

Could you please help me figure out which PINS should microphone connect to & how alsamixer settings


-c1 is mono and that is mic 1

You will either have to create a asound.conf.

 pcm.cap {
 type plug
 slave {
   pcm "my_card"
   channels 8
 route_policy sum

Think that will route all 8 into a mono source so if on any it will come through.
Otherwise -c 8 and record all tracks, but you can do that just to test.

I have mine on mic1 and -c1 works as that is the first channel.

/etc/asound.conf (system wide) or $HOME/asound.rc (user) can be like voodoo just do some googling.

You can also set the default there so no need to continue defining which card.

PS ?
-d, --duration=#

Interrupt after # seconds. A value of zero means infinity. The default is zero, so if this option is omitted then the arecord process will run until it is killed.

I just crtl+C when I want it to stop

Also when you say microphone you mean active module as that is what it needs if just using micp & micn
Otherwise you prob need a little circuit applying the micbias and if its going to be differential or single ended.
I just use modules.

with alsamixer -c1 default settings will work.

1 Like

I followed your advice and it works
Thanks for the help!

1 Like