Rock Pi S Wifi Intermittent Stalls/Hanging

When using a v1.2 Rock Pi S with 512MB of RAM, when connected to the network using WIFI the connection intermittently stalls or hangs and then continues. This is most noticeable when connected over SSH as the console becomes un-responsive for a few seconds. It can also be seen while pinging the router it is connected to:

$ ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
64 bytes from 192.168.1.1: icmp_seq=1 ttl=64 time=4.55 ms
64 bytes from 192.168.1.1: icmp_seq=2 ttl=64 time=4.18 ms

64 bytes from 192.168.1.1: icmp_seq=8 ttl=64 time=6.84 ms
64 bytes from 192.168.1.1: icmp_seq=9 ttl=64 time=3.41 ms
64 bytes from 192.168.1.1: icmp_seq=10 ttl=64 time=4.34 ms
64 bytes from 192.168.1.1: icmp_seq=11 ttl=64 time=5.94 ms
64 bytes from 192.168.1.1: icmp_seq=12 ttl=64 time=6005 ms
64 bytes from 192.168.1.1: icmp_seq=13 ttl=64 time=4998 ms
64 bytes from 192.168.1.1: icmp_seq=14 ttl=64 time=3990 ms
64 bytes from 192.168.1.1: icmp_seq=15 ttl=64 time=2982 ms
64 bytes from 192.168.1.1: icmp_seq=16 ttl=64 time=1974 ms
64 bytes from 192.168.1.1: icmp_seq=17 ttl=64 time=966 ms
64 bytes from 192.168.1.1: icmp_seq=18 ttl=64 time=3.58 ms
64 bytes from 192.168.1.1: icmp_seq=19 ttl=64 time=3.26 ms
64 bytes from 192.168.1.1: icmp_seq=20 ttl=64 time=5.30 ms

I have tried the radxa builds and armbian builds. The Armbian 5.9.x kernel builds improve things greatly but the issue can still be seen. Note, the Armbian 5.10 kernel builds are currently broken.

Are there any pointers on how I should debug this issue? I suspect it is kernel or wifi driver related.

Tested on: rockpis_debian_buster_server_arm64_20210126_0109-gpt.img

You can mitigate this issue by doing the following experiment:

1 - From the board, using a serial console, ping to your PC box. Leave it running.
2 - From your PC box, ping the board. Leave it running.
3 - From your PC box, ssh to the board, see how it goes now.

There is an explanation for this if the following experiment fixes your issue.

I had the same problem, have not found the reason but with armbian legacy I tried to rule out some sources of error:

  • An antenna well connected, because it does not work without.
  • A stable MAC assigned, added in /boot/armbianEnv.txt:
    extraargs=swiotlb=1024 rtl8723ds.rtw_initmac=“00:e0:4c:b2:86:d1”
  • The second WLAN deactivated, new kernel generated:
    rtl8723ds/Makefile Line 1588 near PLATFORM ARM RK3188 comment line
    EXTRA_CFLAGS + = -DCONFIG_CONCURRENT_MODE

Maybe the last point was crucial
Now it works 3 weeks with armbian, bridge from wlan0 to eth0:
Linux PiS 4.4.247-rockpis #1 SMP PREEMPT Sat Jan 30 15:14:13 CET 2021 aarch64 GNU/Linux

1 Like

What kind of Antenna did you use?
How is that connector called?
Its too small SMA, isnt it?

The antenna I have used from an old IMX6 Wandboard Quad.
Possible this:
ANT-P150-A1380-45D-2450-BK

It is the antenna allnetchina sells for the Rock Pi S. I do not think it is the antenna since the behavior changes with newer kernels.

I bought a Delock 86246 U.FL Antenna.
It made Wifi possible for me. Without is was not.
I switched between Linux distributions, but with no significant difference.
Now I run Armbian with some tweaks and it is for me.
Still having hanging Wifi connections from time to time.
Br Kuumaur

Does someone else have issues with the Wifi connection?
I still have every few minutes a freezing Wifi connection.
It does not happen on LAN. Very curios.