Rock Pi S v1.1 New user

I have message ALLNET is shipping for rock-pi-S v1.1 on Aug 1, 2019

My review of the wiki lists gpio info on Hardware V11, is that version v1.1 ?

There is a debian image in the downloads of the wiki, is that compatible with v1.1 ?

Yeah, that’s v1.1.

Fully compatible.

I am using the rockpis_debian_stretch_minimal_arm64_190806_0234-gpt,

everytime I connect to my home wifi it has a different MAC number. I have never seen this
before, my attempt was to use my dhcp router to lockin an assigned ip, however with a
changing mac address I can’t do this.

Is there a setting that fixes the mac address ?

I am facing the same issue. With both of my Rock Pi S.

Quite annoying

Actually I would recommend not to buy the boards right now. The software is not ready yet!
No sound working, DHCP issues, …

And it seems as if no one of Radxa is reacting to issues opened here.

Question on the two buttons ?

  1. the inboard button next to leds (sw9203) appears to be a reset ?

  2. the outboard (sw9204) seems un programmed in latest debian
    Is it the software “suspend” referred to as poweroff in https://wiki.radxa.com/RockpiS/Debian ?
    or is it used for flashing the nand ?

It’s actually secure feature which usually disabled i believe, check this https://blogs.gnome.org/thaller/2016/08/26/mac-address-spoofing-in-networkmanager-1-4-0/

That seems like where the solution would be, however this
is the original file from the image /etc/NetworkManager
-rw-r–r-- 1 root root 98 Aug 5 22:33 NetworkManager.conf

[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false

[device]
wifi.scan-rand-mac-address=no

Read whole article. NetworkManager.conf is not file you looking for, for now at least. Read “Global Default Configuration” part

Thanks , I’m a little slow sometimes … but this seems to stabilize the mac

created a file
sudo nano /usr/lib/NetworkManager/conf.d/rock.conf

[device-mac-randomization]
wifi.scan-rand-mac-address=yes

[connection-mac-randomization]
wifi.cloned-mac-address=stable
1 Like

Good, no idea why rand was default option, but oh well, at least it’s fixed