ROCK Pi S crashes on boot [SOLVED]

New to the Rock PI S, so bear with me as I am getting up to speed.

Got my Rock Pi S (v1.2) with 512Mb Ram and 1Gb Nand yesterday. Followed the ‘Getting started’ instructions from Flashed ubuntu image to an SD card [sandisk extreme 32Gb]and plugged it into the Rock Pi S. Supplied power via the USB-C USB-A cable, connected a USB 232 serial adapter to pin 6,8,10.

And I see the Rk3308 booting up. COOL. It boots up all the way and start several services and prints
‘Welcome to Ubuntu 18.04 LTS!’, but no prompt.

it sits there for a second or two, and then it resets.

then you see the message DDR Version V1.26 … followed by U-boot and it restarts.
This then repeats over and over.

tried different images:

Same story. They all show the same behavior.

What am I missing? is there a watchdog running?
and one point it succeeded yesterday and I was able to log in. But I tried now all morning and it consistantly fails.

ADDON led info:
I see the green led coming on, and shortly after the blue one flashes twice. Then all leds go off.


Here the last line I see in the console:

[ 1.570925] Key type dns_resolver registered
[ 1.571793] flash vendor_init_thread!
[ 1.572162] flash vendor storage:20170308 ret = -1
[ 1.573254] registered taskstats version 1
[ 1.590018] Key type encrypted registered
[ 1.591512] hctosys: unable to open rtc device (rtc0)
[ 1.606701] ALSA device list:
[ 1.607031] #0: Loopback 1
[ 1.607307] #1: rockchip,rk3308-acodec
[ 1.608365] Freeing unused kernel memory: 384K
Loading, please wait…
starting version 237
Begin: Loading essential drivers … done.
Begin: Running /scripts/init-premount … done.
Begin: Mounting root file system … Begin: Running /scripts/local-top … done.
Begin: Running /scripts/local-premount … done.
Warning: fsck not present, so skipping root file system
[ 2.418695] EXT4-fs (mmcblk0p2): mounted filesystem with ordered data mode. Opts: (null)
Begin: Running /scripts/local-bottom … done.
Begin: Running /scripts/init-bottom … done.
[ 3.066284] systemd[1]: System time before build time, advancing clock.
[ 3.072673] cgroup: cgroup2: unknown option “nsdelegate”
[ 3.090803] systemd[1]: systemd 237 running in system mode. (+PAM +AUDIT +SELINUX +IMA +APPARMOR +SMACK +SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ +LZ4 +SECCOMP +BLKID +ELFUTILS +KMOD -IDN2 +IDN -PCRE2 default-hierarchy=hybrid)
[ 3.094314] systemd[1]: Detected architecture arm64.

Welcome to Ubuntu 18.04 LTS!

[ 3.117620] systemd[1]: Set hostname to ‘rockpis’.

DDR Version V1.26 <=== this indicates the reset and reboot
REGFB: 0x00000032, 0x00000032

PS: if needed I can post the entire output

And attached to a 500mA source?

Thank for your response ‘igorp’.

After noticing that the problem always seems to occur when both LED are on,
(regardless which distro i used.) I came to think of, maybe it runs out of juice.

Started switching to a Samsung 2.1 power usb adapter ( instead of USB A outlet of my notebook) and YES that solved the problem.

I guess the 2 leds just pulled enough additional current and pushed it over the edge.