Rock Pi S as Access Point

Has anyone been able to get this board working as a WiFi access point? I cannot get past:

rock@rockpis:~$ sudo service isc-dhcp-server start

Job for isc-dhcp-server.service failed because the control process exited with error code.
See “systemctl status isc-dhcp-server.service” and “journalctl -xe” for details.

Any thoughts?

Yes, this way:

You need the output of this for others to help you.

We have a wiki page for ap mode:

Hello igorp,
Thank you for the reply. However, I’m using the Rock Pi S which doesn’t have an Armbian image that I know of… definitely not one that’s supported. I am familiar with Armbian and how great it is (i’m running it on both my Tinkerboards). If you’ve gotten Armbian with armbian-config to work on the Rock Pi S, please tell me how you were able to do so.

Thanks for your help.

Thank you for your help. I’m new to forums, I have the output of journalctl -xe in a .txt file but can attach it. The Forum is also saying it’s too big to leave in comment.

What’s the best way to get that output to those who can help? Sorry for the newness. :slight_smile:

Hi there,
I am trying almost the similar but reverse thing. I wanted to have the RockPiS serving an ethernet port across the wall and therefore running DHCP server on the ethernet port with a static IP and routing via NAT/iptables the data through the Wifi across the wall (where I am not able to drill a hole…)
I have almost everything set up, I tried to use the debian stretch and today also the most recent debian buster image but I don’t get it working :frowning:
The ethernet port just behaves “strange” and sometimes even can not ping. I am almost giving up… but need to double… triple check my configuration before I complain. But from the current point the RockPiS seems to be not behaving normal…

You can paste the output to pastebin:

and send the link here.

Thank You Jack,
I was able to get the isc-dhcp-server working by entering:

sudo ifconfig wlan0

which the server in the /etc/dhcp/dhcpd.conf file. This allowed the service to start.
I eventually just put that ifconfig command at the top of /etc/init.d/isc-dhcp-server file and it worked on boot. Probably very hacky, but it boots with dhcp service running!

1 Like