Rock Pi Model C+ Wifi automatically disables itself and Bluetooth doesn't work

Wifi disables itself after some time and the Bluetooth doesn’t work at all.

I also need to disable bluetooth scanning or this message will pop-up and disappear in a split second saying that bluetooth stopped working.

Its good to report more information when you report an error, eg what OS/desktop environment you are using.

It could be that power management is disabling your wifi/bluetooth to save power. If you don’t care abou the tiny power saving, you could install tlp

On ArchLinux or Manjaro, this is done with:
pacman -S tlp
systemctl enable --now tlp

My /etc/tlp.conf (optimised for performance, not power saving. Read the comments in that config file, some settings mean the opposite of what they sound like):

DEVICES_TO_ENABLE_ON_AC=“wifi bluetooth”

I’m using Android 11 official radxa image. Also how do I disable the serial console? It says it on and impacting performance in the notification tab. I also get a “bluetooth keeps stopping” error message that pops up and disappears quickly when I have bluetooth scanning turned on. The bluetooth stops working after the first restart on a fresh image flash.

Hi Reclusive,

Sorry I aasumed you were using linux. I don’t know if tlp works on Android.

When you have a different question, you should post it seperately. Forums become impossible to use when the answer to the original question is buried amongst unrelated stuff :slightly_smiling_face:

have you solved this ? i have exactly the same issue…offical android 11 on rock pi4c+ : wifi keep disconnecting after a while

1 Like

Hi, I also have the same issue. Did you guys find a solution ?

Hi there,

Is there anybody that solved this problem?
I have it to on my official Radxa Android version.